www.sp.gov.br doesn't work without the www

RESOLVED INVALID

Status

Tech Evangelism
Mobile
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: Leo Balter, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mobile-compat-form][country-br], URL)

(Reporter)

Description

4 years ago
Site: http://www.sp.gov.br
www.sp.gov.br doesn't  work without the www

:: Steps To Reproduce

1. I try to access sp.gov.br on any device (I don't like to type www)
2. I get a Server Not Found error

this occours on ANY device and browser, from mobile to desktop.

:: Expected Result

I would like to be redirected to www.sp.gov.br because in mobile every letter I type does matter.

:: Actual Result

Server Not Found error

:: Additional Information

Software Version: Firefox OS 1.1.0.1
Device Information: LG Fireweb D300. Firefox OS 1.1
Reporter's User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:28.0) Gecko/20100101 Firefox/28.0
(Reporter)

Updated

4 years ago
Whiteboard: [mobile-compat-form] → [mobile-compat-form][country-br]
(Reporter)

Comment 1

4 years ago
To help making you aware, sp.gov.br is for the Sao Paulo government, the biggest state of Brazil and it contains public services stuff.
Yeah, their webmasters need to fix that at the DNS level (probably by adding an A record, see https://support.google.com/a/answer/48090?hl=en#H). But since this restricted to Firefox OS or Firefox for Android, we probably shouldn't spend too much effort on reaching out for them to fix it, hence closing as INVALID.

That said, if someone has a contact--please reach out, it is a pretty crappy experience!

mtaylor at omg-2 in ~/tmp
$ http --print=Hh GET http://sp.gov.br
GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: sp.gov.br
User-Agent: HTTPie/0.6.0

HTTP/1.0 303 See Other
Connection: close
Content-Length: 0
Date: Tue, 05 Nov 2013 20:36:47 GMT
Location: http://guidetest.a.id.opendns.com/?url=sp%2Egov%2Ebr
Server: OpenDNS Guide

mtaylor at omg-2 in ~/tmp
$ http --print=Hh GET http://www.sp.gov.br
GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.sp.gov.br
User-Agent: HTTPie/0.6.0

HTTP/1.1 302 Redirect
Content-Length: 152
Content-Type: text/html
Date: Tue, 05 Nov 2013 20:38:36 GMT
Location: http://www.saopaulo.sp.gov.br
Server: Microsoft-IIS/6.0
X-Powered-By: ASP.NET
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(Feel free to reopen if anyone disagrees btw.)
You need to log in before you can comment on or make changes to this bug.