Closed Bug 934166 Opened 8 years ago Closed 8 years ago

Intermittent IOError: [Errno 2] No such file or directory: '.deps/host_nsinstall.i_o.pp'

Categories

(Firefox Build System :: General, defect)

All
Linux
defect
Not set
normal

Tracking

(firefox26 unaffected, firefox27 fixed, firefox28 fixed, firefox-esr24 unaffected)

RESOLVED FIXED
mozilla28
Tracking Status
firefox26 --- unaffected
firefox27 --- fixed
firefox28 --- fixed
firefox-esr24 --- unaffected

People

(Reporter: philor, Assigned: glandium)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

We've been calling this clobber-needed for what seems like weeks, and now we're calling it clobberer-needs-to-be-fixed, and I'm beginning to doubt it's true.

https://tbpl.mozilla.org/php/getParsedLog.php?id=30033159&tree=Mozilla-Inbound

mkdir -p "subtiers/base/"
make[6]: Entering directory `/builds/slave/m-in-lx-pgo-000000000000000000/build/obj-firefox/config'
Traceback (most recent call last):
  File "/tools/python27/lib/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/tools/python27/lib/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/builds/slave/m-in-lx-pgo-000000000000000000/build/python/mozbuild/mozbuild/action/link_deps.py", line 223, in <module>
    main(sys.argv[1:])
  File "/builds/slave/m-in-lx-pgo-000000000000000000/build/python/mozbuild/mozbuild/action/link_deps.py", line 213, in main
    linker.add_dependencies(open(f))
IOError: [Errno 2] No such file or directory: '.deps/host_nsinstall.i_o.pp'
make[6]: Leaving directory `/builds/slave/m-in-lx-pgo-000000000000000000/build/obj-firefox/config'

https://tbpl.mozilla.org/php/getParsedLog.php?id=30032620&tree=Mozilla-Aurora

mkdir -p "subtiers/base/"
make[6]: Entering directory `/builds/slave/m-aurora-l64-00000000000000000/build/obj-firefox/config'
Traceback (most recent call last):
  File "/tools/python27/lib/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/tools/python27/lib/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/builds/slave/m-aurora-l64-00000000000000000/build/python/mozbuild/mozbuild/action/link_deps.py", line 223, in <module>
    main(sys.argv[1:])
  File "/builds/slave/m-aurora-l64-00000000000000000/build/python/mozbuild/mozbuild/action/link_deps.py", line 213, in main
    linker.add_dependencies(open(f))
IOError: [Errno 2] No such file or directory: '.deps/host_nsinstall.i_o.pp'
make[6]: Leaving directory `/builds/slave/m-aurora-l64-00000000000000000/build/obj-firefox/config'
So, the problem is "simply" that non-clobber pgo builds are currently broken. I'm actually kind of surprised we allow incremental pgo builds at all...
Just disable pseudo derecurse on pgo builds for now.
Attachment #826536 - Flags: review?(mshal)
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED
Duplicate of this bug: 933090
Attachment #826536 - Flags: review?(mshal) → review+
https://hg.mozilla.org/mozilla-central/rev/c698de28d69d
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
Glandium, can you please request Aurora approval for this?
Comment on attachment 826536 [details] [diff] [review]
Disable pseudo derecurse on PGO builds

[Approval Request Comment]
Bug caused by (feature/regressing bug #): pseudo derecursed build system
User impact if declined: PGO build failure when the build is incremental (rare, but happens)
Risk to taking this patch (and alternatives if risky): The patch only makes us go back to the old build behavior for PGO builds.
String or IDL/UUID changes made by this patch: None.
Attachment #826536 - Flags: approval-mozilla-aurora?
Comment on attachment 826536 [details] [diff] [review]
Disable pseudo derecurse on PGO builds

low risk patch, helps avoid intermittent PGO build failures
Attachment #826536 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.