[flatfish][Bluetooth][JB only]AVRCP is not working due to uinput event was not been generated

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: shawnjohnjr, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:1.3+, firefox28 fixed)

Details

(Whiteboard: [Flatfish only][developer+])

We found uninput was not been generated. So shell.js cannot receive any of AVRCP media button key event.
This bug looks like related to JB + BlueZ.

Updated

5 years ago
blocking-b2g: --- → koi?
Whiteboard: [Flatfish only]

Updated

5 years ago
Whiteboard: [Flatfish only] → [Flatfish only][developer+]
I have helped to check bluez part.
I found this is caused by /dev/uinput permission incorrect which cause bluez bluetoothd cannot open uinput device node. Again, Sam will help on submit patch to system/core/rootdir/ueventd.rc.
Close this bug.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Note: /dev/uinput change to net_bt_stack
Summary: [flatfish][Bluetooth]AVRCP is not working due to uinput event was not been generated → [flatfish][Bluetooth][JB only]AVRCP is not working due to uinput event was not been generated
(In reply to Shawn Huang from comment #3)
> Note: /dev/uinput change to net_bt_stack 
In this way we give the bluetooth file access to Bluetooth api of all.
In JB,  framework/base/data/etc/platform.xml defines
   <permission name="android.permission.BLUETOOTH_STACK" >
        <group gid="net_bt_stack" />
    </permission>
/dev/uinput group permission changes from bluetooth to net_bt_stack, because packages/apps/Bluetooth uses bluedroid library and it uses android.permission.BLUETOOTH_STACK
So this is why JB changes permission.

Updated

5 years ago
blocking-b2g: koi? → 1.3?

Updated

5 years ago
blocking-b2g: 1.3? → 1.3+
status-firefox28: --- → fixed
You need to log in before you can comment on or make changes to this bug.