Closed Bug 934503 Opened 6 years ago Closed 6 years ago

Activated hidden plugins (Flash) show the blue plugin icon

Categories

(Core :: Plug-ins, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla28
Tracking Status
firefox26 + verified
firefox27 + verified
firefox28 --- verified
b2g-v1.2 --- fixed

People

(Reporter: benjamin, Assigned: benjamin)

References

Details

(Keywords: regression)

Attachments

(2 files)

The blue plugin notification icon is only supposed to be shown when the plugin is not active. In today's nightly http://benjamin.smedbergs.us/tests/ctptests/flash-hidden.html shows the blue icon. This is a regression from bug 745187. I think I already have it fixed in another prototype in my tree, but I'm going to try and split it out to get it fixed now.
Assignee: nobody → benjamin
Status: NEW → ASSIGNED
Attachment #826961 - Flags: review?(jaws)
https://hg.mozilla.org/integration/fx-team/rev/a8131d677d9b
https://hg.mozilla.org/integration/fx-team/rev/f631148645b3

This will be uplifted with the patch that regressed it.
Target Milestone: --- → mozilla28
https://hg.mozilla.org/mozilla-central/rev/33fdb96c1ead
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Keywords: verifyme
Verified as fixed using the following environment:
FF 26 beta 3
Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build Id:20131107161719
OS: Win 7 x64
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #0)
> The blue plugin notification icon is only supposed to be shown when the
> plugin is not active. In today's nightly
> http://benjamin.smedbergs.us/tests/ctptests/flash-hidden.html shows the blue
> icon. 
Still remains blue if Flash is CTP blocked and allowing. But it gets normal after refresh.
What do you think?
Flags: needinfo?(benjamin)
Do you mean that if flash is blocked, and then you allow it via the doorhanger, the icon remains blue? I think that's the expected behavior.
Flags: needinfo?(benjamin)
But that means the plugin is active, so it's contrary to:
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #0)
> The blue plugin notification icon is only supposed to be shown when the
> plugin is not active.
Once we've shown the icon, we don't want to change it until the next page load. It would be weird flickering.
Thanks for explaining.
Verified fixed 28.0a1 (2013-11-10) Win 7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0

Verified as fixed on latest Aurora 27.0a2 (buildID: 20131121004004).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.