Closed Bug 934537 Opened 6 years ago Closed 6 years ago

[Contacts] Trying to edit a contact generates a "Duplicate found" message

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3+)

RESOLVED WORKSFORME
1.3 Sprint 6 - 12/6
blocking-b2g 1.3+

People

(Reporter: marcia, Assigned: gtorodelvalle)

Details

(Keywords: dataloss, regression, reproducible, Whiteboard: [xfail])

Attachments

(4 files)

Buri, while running the latest nightly build:

STR:
1. Create a new contact
2. Save the contact
3. Edit the contact (I added a company name)

Expected: The contact would be edited
Actual: Duplicates Found Message 

Screenshot and adb coming as soon as I can get adb working again on this mac.
QA Contact: nkot
Regression range:

-last working-
BuildID: 20131031040201
Gaia: 412fd463bcb81f0e8bebf6d32500d0c02712748d
Gecko: f0d363d72753
Version: 28.0a1
Firmware: 20131015

-first broken-
BuildID: 20131101040203
Gaia: ccdf357ea150fc7d8b8a4b74c7adf31e7a57e465
Gecko: abe6790a5dd8
Version: 28.0a1
Firmware: 20131015
Here are the exact STR using today's build:

1. Add a new contact, adding just the name (first and last) and phone number
2. Edit the contact -> add a company name
3. Receive the duplicates message

Using Buri: 

Gaia   5c2929cd15ac020f85026030387aed9eb322362d
SourceStamp 770de5942471
BuildID 20131105040208
Version 28.0a1
ayman will be doing a quick test
Flags: needinfo?(aymanmaat)
(In reply to Joe Cheng [:jcheng] from comment #5)
> ayman will be doing a quick test

I cannot reproduce this. 
Steps i took were following:

1) open empty contacts app
2) select add contact 
3) enter first name, last name and phone number
4) select done to create contact
5) select contact created in step 4 in contact list.
6) select edit
7) add company name
8) select done

**Actual**
Contact updated, no message about finding duplicate communicated.

**Build info**
unagi-ICS.
user.
master.
debugRilAndMmsServiceON.
Gecko-cdb7ea3.
Gaia-485c7b6

ni? to Marcia to confirm i have followed the correct steps
Flags: needinfo?(mozillamarcia.knous)
Flags: needinfo?(aymanmaat)
The steps in Comment 6 are the same STR I am following, but I had previously added 1 or 2 contacts before adding another one. Can still be reproduced consistenly using:

Gaia   7243b75041c93bc7deb240131748d0b164f3f0b0
SourceStamp 7b014f0f3b03
BuildID 20131113040200
Version 28.0a1
Base Image: 11-11
Flags: needinfo?(mozillamarcia.knous)
Whiteboard: [xfail]
Attached file steps to reproduce.pdf
I was reproduced in other procedures.
I will attach a screen shot.
Flags: needinfo?(mozillamarcia.knous)
Teiichiro - You added needs info, but you didn't specify what you would like me to test :)
Flags: needinfo?(mozillamarcia.knous)
Keywords: reproducible
There are a couple of Gaia changes around this timeframe, but both don't seem likely to be the cause of this bug:

https://github.com/mozilla-b2g/gaia/commit/7b11666842e7c79d87547c821c084d4c6fa70447
https://github.com/mozilla-b2g/gaia/commit/6437331665431195afb116d8a285df2450ae5830

I'll check the gecko commits as well.
A suspicious candidate for causing this regression is bug 898337.

Julien - What do you think?
Flags: needinfo?(felash)
Just for information: I got this issue when editing a contact that is in the reference workloads. The most important issue I saw is that when we accept the deduplication, the contact is deleted! So clearly this is a dataloss issue.

Jason: clearly this is the most suspicious but it won't cause this bug alone. Needinfo Francisco on this
Flags: needinfo?(felash) → needinfo?(francisco.jordano)
Also, when I tried to get this issue again, I didn't get it. So there must be something else happening.
Some test automation that was hit by this is now passing on the latest nightly but I wouldn't take that as a 'fixed' , there seem to be numerous use cases to replicate this.
Whiteboard: [xfail]
There is one question.
When you save a new contact, duplication judgment is required.
However, I think that a duplication judging is not needed when updating registered contact.
It is unquestionable if the contact is overwrited.
Why is the duplication judgment executed when the contact is updated?
Whiteboard: [xfail]
Teiichiro-san has a point here. Maybe dedup should never be done on updating a contact.

AFAIK the contact matcher algorithm does not currently try to match by "name", only by "tel" and "email" so I fail to see why bug 898337 would trigger this.
ayman will do another test
Flags: needinfo?(aymanmaat)
(In reply to Joe Cheng [:jcheng] from comment #18)
> ayman will do another test

Why is this necessary? We're breaking automated test here, so this is clearly a regression from something that used to work.
Changing needinfo to Jose Manuel, sure he can provide better feedback here.
Flags: needinfo?(francisco.jordano)
Ok i can confirm that this is a bug. and we should block with it

Steps to reproduce are:

1) ensure that there is at least one other contact in the contact list. (the contact list must not be empty)
2) open contact list
3) select add contact 
4) enter first name, last name and phone number none of which correspond to the strings associated to an existing contact in the contact list (to ensure there is absolutely no correlation of data and therefore no chance of duplication being found) 
5) select done to create the new contact
6) select contact created in step 5 in contact list.
7) select edit
8) add company name that in no way correlates to a company name associated to any other contact in the list (to ensure there is absolutely no correlation of data and therefore no chance of duplication being found) 
9) select done

**Expected**
Contact updated, no message about finding duplicate is presented.

**Actual**
Dialogue informing the user that a duplicate for the updated contact has been found is presented indicating the duplicate that has been found is actually the contact that has just been updated

**Build info**
unagi-ICS.
user.
master.
Rel0.4.
Sprint12.
B-195.
Gecko-6ebfdca.
Gaia-298e6c5

recommend to block on the grounds that a given Contact should never find itself being offered as a duplicate of itself.
Flags: needinfo?(aymanmaat)
Ayman, have you also reproduced what I said in comment 13? When you accept the dedup, the contact is just deleted?
Flags: needinfo?(aymanmaat)
(In reply to Teiichiro Fukuda from comment #16)
> There is one question.
> When you save a new contact, duplication judgment is required.
> However, I think that a duplication judging is not needed when updating
> registered contact.
> It is unquestionable if the contact is overwrited.
> Why is the duplication judgment executed when the contact is updated?

We need duplicate judgment when a contact is updated because the update could actually lead to a duplicate being created and in this situation we need to highlight duplication.
Flags: needinfo?(aymanmaat)
(In reply to Julien Wajsberg [:julienw] from comment #22)
> Ayman, have you also reproduced what I said in comment 13? When you accept
> the dedup, the contact is just deleted?

...I have now ;P 
and in this case it is a catastrophic error because, as you point out, the contact is deleted and so the user experiences an unrecoverable loss of information.

Block.
(In reply to Francisco Jordano [:arcturus] (on PTO till 18/11) from comment #20)
> Changing needinfo to Jose Manuel, sure he can provide better feedback here.

adding ni? to Jose as it seems Francisco missed it.
Flags: needinfo?(jmcf)
Keywords: dataloss
I'd like to know if that happens in 1.2 (I doubt it, but I'd rather be safe than sorry for this). See comment 21 for a precise STR.
Keywords: qawanted
(In reply to Julien Wajsberg [:julienw] from comment #26)
> I'd like to know if that happens in 1.2 (I doubt it, but I'd rather be safe
> than sorry for this). See comment 21 for a precise STR.

This doesn't reproduce on 1.2 - we've never seen this in daily smoketests & automation.
Keywords: qawanted
Assignee: nobody → gtorodelvalle
Flags: needinfo?(jmcf)
1.3+ for regression
blocking-b2g: 1.3? → 1.3+
Target Milestone: --- → 1.3 Sprint 6 - 12/6
Duplicate of this bug: 942010
Hi guys, I am not able to reproduce this bug in v1.2 (Gecko-6ac8a1e.Gaia-264c604) or in master (Gecko-b79ea77.Gaia-671a7c1), so it was probably a regression successfully solved.

Would you be so kind to retest it, please? Thanks!
Keywords: qawanted
QA Contact: nkot → sparsons
I was not able to repro this issue on the Buri 1.3 Build ID: 20131126052050

Gaia   4ad796b196d468bdb231beba4392acbc90a74e96
SourceStamp 99479edbee2a
BuildID 20131126052050
Version 28.0a1

Also, this issue does not repro on Buri 1.2 Build ID: 20131126004001

Gaia   264c6044b941437ac3c4b28fe4ca392d2bc78445
SourceStamp 21e2ad082d85
BuildID 20131126004001
Version 26.0
Keywords: qawanted
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Buri
Gaia:     d4b9a3d271f0451b4d903a03c2b931b8cc092041
Gecko:    http://hg.mozilla.org/mozilla-central/rev/6ecf0c4dfcbe
BuildID   20131127040203
Version   28.0a1
ro.build.version.incremental=eng.archermind.20131114.105818


I still can reproduce (both 20131126052050 and 20131127040203 build) by gaia-ui-tests on my PC and TWCI with different Buri.
$ gaiatest --address=localhost:2828 --testvars=testvars.json --restart gaiatest/tests/functional/contacts/test_add_photo_to_contact.py
But I cannot reproduce manually.

IMO, manually operate the Contacts app is fine (Bug 934537), however the Javascript WebAPI is broken (Bug 942010).
I can replicate this manually and so can Bebe (see below).

I used a User build, just to eliminate the Engineering build as a difference:

Gaia:     d4b9a3d271f0451b4d903a03c2b931b8cc092041
Gecko:    http://hg.mozilla.org/mozilla-central/rev/6ecf0c4dfcbe
BuildID   20131127040203
Version   28.0a1

Exact STR:
1. Flash with new build.
2. Skip through FTU
3. Load contacts app
4. Tap new Contact
5. Enter a first name, surname, company and telephone number
6. Tap Done 
7. Tap back into details page for contact just created
8. Tap 'Edit'
9. Tap 'Add picture'
10. Choose gallery (or camera if there is no picture on the SD card)
11. Select the image
12. don't crop, just select 'Done'
13. Tap 'Update'
14. Duplicates found will appear

I'm re-opening as I have replicated this over a dozen times this morning and I don't think it is some kind of fluke.



---- Cross post from Bug #934537

I can replicate this manually on:
Gaia:     d4b9a3d271f0451b4d903a03c2b931b8cc092041
Gecko:    http://hg.mozilla.org/mozilla-central/rev/6ecf0c4dfcbe
BuildID   20131127040203
Version   28.0a1


If it's not reproducing the first time give it a second one.

Keep in mind you have to have a picture on the SD card
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
I think we need to open a separate bug for what you found, only because there can be different reasons why duplicate found can fire. The original bug focused on company name. Can you open a new bug for the gallery image use case?
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Flags: needinfo?(zcampbell)
Resolution: --- → WORKSFORME
(In reply to Jason Smith [:jsmith] from comment #34)
> I think we need to open a separate bug for what you found, only because
> there can be different reasons why duplicate found can fire. The original
> bug focused on company name. Can you open a new bug for the gallery image
> use case?

Actually, let's just use bug 942010 to track that.
Flags: needinfo?(zcampbell)
I am encountering this exact same issue on the Buri v 1.3.0 Mozilla RIL

Environmental Variables
Device: Buri v 1.3.0 Mozilla RIL
Build ID: 20131218004002
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/369bdbff6c38
Gaia: a99b23e73fe5630a877004746d0e7fcec1b6d653
Platform Version: 28.0a2

The user is prompted "Duplicates found" every time they edit the phone number or the company name. 

Should we write up a new issue or reopen this one?
(In reply to ktucker from comment #36)
> I am encountering this exact same issue on the Buri v 1.3.0 Mozilla RIL
> 
> Environmental Variables
> Device: Buri v 1.3.0 Mozilla RIL
> Build ID: 20131218004002
> Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/369bdbff6c38
> Gaia: a99b23e73fe5630a877004746d0e7fcec1b6d653
> Platform Version: 28.0a2
> 
> The user is prompted "Duplicates found" every time they edit the phone
> number or the company name. 
> 
> Should we write up a new issue or reopen this one?

Open a new bug.
Hi guys, I think the bug ktucker has found in 1.3 is due to the patch which solves bug 942010 not being uplifted to 1.3 yet. Have you already created this new bug, ktucker? If yes, I would say it is a candidate to be a duplicate of 942010 :-) Thanks!
Flags: needinfo?(ktucker)
I will not write up a bug on this issue then. Thank you for the information!
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.