[B2G][FM Radio] Radio audio can be heard for a quick moment after answering an incoming call

RESOLVED DUPLICATE of bug 862899

Status

Firefox OS
Gaia::FMRadio
RESOLVED DUPLICATE of bug 862899
5 years ago
5 years ago

People

(Reporter: Matthew Vaughan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: burirun3)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 826836 [details]
LogCat of FM Radio audio being heard for a moment when answering phone call.

Description:
The FM Radio audio can be heard for a quick moment after the user answers an incoming phone call. This audio can be heard between when the user taps the "accept call" button and the "active call" screen loads. The audio can only be heard for about 0.2 seconds.

Repro Steps:
1) Update Buri to v1.2 comRIL BuildID: 20131030004003
2) Launch the FM Radio app
3) Begin listening to a radio station
4) Make a call to the test device from another device
5) Tap the "accept call" button to answer the call

Actual:
The Radio audio can be heard for a quick moment after tapping the "accept call" button but before the "active call" screen loads.

Expected:
The Radio audio cannot be heard at all from the first ring to the end of the phone call.

Environmental Variables:
Device: Buri v1.2 comRIL
BuildID: 20131030004003
Gaia: a788ea1a3e04716938bd41a559c36a831cf1190b
Gecko: 4fbe1b01ed63
Version: 26.0a2
RIL Version: 01.01.00.019.264

Notes:
Repro frequency: 5/5
Link to failed test case: https://moztrap.mozilla.org/manage/case/4525/
See attached: LogCat

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 862899
You need to log in before you can comment on or make changes to this bug.