Closed Bug 934701 Opened 7 years ago Closed 7 years ago

Clicking on line number in console doesn't open debugger

Categories

(DevTools :: Console, enhancement)

26 Branch
x86
macOS
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 670002

People

(Reporter: todd, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131024004004

Steps to reproduce:

1. Load web page with javascript files that contain source maps and there's an error in them
2. Open the console and see the error. Note the error is for the non-source mapped line number
3. Click on error



Actual results:

The "view source" modal opened with my line highlighted.


Expected results:

It should have opened the debugger with the source-map linked file "opened" with the line from that file highlighted.
Severity: normal → enhancement
Component: Untriaged → Developer Tools: Console
I think this falls within the purview of bug 670002. Nick, please reopen if I'm wrong.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 670002
Yes, we don't yet use source maps in the webconsole or profiler, only the debugger.
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.