[AccessFu] Error when encountering an input type="date"

RESOLVED FIXED in Firefox 28

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: eeejay, Assigned: yzen)

Tracking

({regression})

unspecified
mozilla28
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox26 unaffected, firefox27 affected, firefox28 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment, 2 obsolete attachments)

[AccessFu] ERROR Error handing accessible event:
 Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]
  _addType@resource://gre/modules/accessibility/OutputGenerator.jsm:224
  _generateBaseOutput@resource://gre/modules/accessibility/OutputGenerator.jsm:330
  defaultFunc@resource://gre/modules/accessibility/OutputGenerator.jsm:500
  entry@resource://gre/modules/accessibility/OutputGenerator.jsm:365
  genForObject@resource://gre/modules/accessibility/OutputGenerator.jsm:121
  addOutput@resource://gre/modules/accessibility/OutputGenerator.jsm:61
  genForContext@resource://gre/modules/accessibility/OutputGenerator.jsm:83
  SpeechPresenter_pivotChanged@resource://gre/modules/accessibility/Presentation.jsm:456
  Presentation_pivotChanged@resource://gre/modules/accessibility/Presentation.jsm:563
  handleAccEvent@resource://gre/modules/accessibility/EventManager.jsm:175
  observe@resource://gre/modules/accessibility/EventManager.jsm:597
  moveToPoint@chrome://global/content/accessibility/content-script.js:101
QA Contact: yura.zenevich
Assignee: nobody → yura.zenevich
QA Contact: yura.zenevich
Posted patch 934737 patch v1 (obsolete) — Splinter Review
Attachment #827200 - Flags: review?(eitan)
Comment on attachment 827200 [details] [diff] [review]
934737 patch v1

OK, getting this approved for Aurora might prove...interesting...But maybe not since this is a completely new ID instead of a changed one.
Keywords: regression
Comment on attachment 827200 [details] [diff] [review]
934737 patch v1

Review of attachment 827200 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good for this specific case. I think the get localized string line should be in a try block, maybe with a warning if an exception occurs. I am worried that other input types will keep cropping up.
Attachment #827200 - Flags: review?(eitan) → review-
Posted patch 934737 patch v2 (obsolete) — Splinter Review
Added try/catch.
Attachment #827200 - Attachment is obsolete: true
Attachment #827596 - Flags: review?(eitan)
Comment on attachment 827596 [details] [diff] [review]
934737 patch v2

Review of attachment 827596 [details] [diff] [review]:
-----------------------------------------------------------------

::: accessible/src/jsat/OutputGenerator.jsm
@@ +223,5 @@
> +    try {
> +      aDesc.push(gStringBundle.GetStringFromName(typeName));
> +    } catch (x) {
> +      Logger.logException(x, 'Failed to get a string from a bundle for ' +
> +        typeName);

How about just a Logger.warning with enough info?

@@ +225,5 @@
> +    } catch (x) {
> +      Logger.logException(x, 'Failed to get a string from a bundle for ' +
> +        typeName);
> +    } finally {
> +      return;

This is redundant, no?
Attachment #827596 - Flags: review?(eitan) → review+
(In reply to Eitan Isaacson [:eeejay] from comment #5)
> Comment on attachment 827596 [details] [diff] [review]
> 934737 patch v2
> 
> Review of attachment 827596 [details] [diff] [review]:
> -----------------------------------------------------------------
> @@ +225,5 @@
> > +    } catch (x) {
> > +      Logger.logException(x, 'Failed to get a string from a bundle for ' +
> > +        typeName);
> > +    } finally {
> > +      return;
> 
> This is redundant, no?
I think not having finally gives warnings in debug builds.
Carrying over a r+ from eeejay.
Attachment #827596 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/2225ed86f53e
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.