Closed Bug 934776 Opened 7 years ago Closed 4 years ago

Add padLeft, padRight features for javascript strings

Categories

(Core :: JavaScript Engine, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1260509

People

(Reporter: kgrandon, Unassigned)

Details

In FirefoxOS land we have several definitions of padLeft defined in content. It would be nice if the platform could support this for us.

I'm not sure what the proper process is for requesting this, so if there's anything I need to do differently please let me know.

.net implementations for example:
padLeft: http://msdn.microsoft.com/en-us/library/92h5dc07%28v=vs.110%29.aspx
padRight: http://msdn.microsoft.com/en-us/library/36f2hz3a%28v=vs.110%29.aspx
The process is to propose such additions on the es-discuss mailing list:

https://mail.mozilla.org/listinfo/es-discuss

Now that TC39 is functional, we generally expect to have a reasonably thought-out, accepted proposal there before we implement any new feature.
(In reply to Jeff Walden [:Waldo] (remove +bmo to email) from comment #1)
> The process is to propose such additions on the es-discuss mailing list:
> 
> https://mail.mozilla.org/listinfo/es-discuss
> 
> Now that TC39 is functional, we generally expect to have a reasonably
> thought-out, accepted proposal there before we implement any new feature.


The window for new ES6 is closed, but I'd be willing to champion this in the committee for ES7
I'm new to es-discuss and standards bodies, but I've created the following draft proposal: https://gist.github.com/KevinGrandon/8423533

Rick - if you're still interested I'd love to work with you on this. Let me know here, or offline, if you are interested.

Ni? so you are alerted.
Flags: needinfo?(waldron.rick)
(In reply to Kevin Grandon :kgrandon from comment #3)
> I'm new to es-discuss and standards bodies, but I've created the following
> draft proposal: https://gist.github.com/KevinGrandon/8423533
> 
> Rick - if you're still interested I'd love to work with you on this. Let me
> know here, or offline, if you are interested.
> 
> Ni? so you are alerted.

Thanks! I posted feedback to gist.
Flags: needinfo?(waldron.rick)
Current version of the proposal:

https://github.com/tc39/proposal-string-pad-start-end

In particular, it was renamed `padStart` and `padEnd`.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1260509
You need to log in before you can comment on or make changes to this bug.