Closed Bug 934794 Opened 6 years ago Closed 6 years ago

Intermittent test_streams_tracks.html | Test timed out.

Categories

(Core :: Audio/Video, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla30
Tracking Status
firefox28 --- wontfix
firefox29 --- fixed
firefox30 --- fixed
firefox-esr24 --- unaffected
b2g-v1.3 --- fixed
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed

People

(Reporter: KWierso, Assigned: jwwang)

References

Details

(Keywords: intermittent-failure)

Attachments

(2 files)

https://tbpl.mozilla.org/php/getParsedLog.php?id=30108761&tree=Mozilla-Inbound
slave: panda-0093


17:58:13     INFO -  19014 INFO TEST-START | /tests/content/media/test/test_streams_tracks.html
17:58:13     INFO -  19015 INFO TEST-INFO | /tests/content/media/test/test_streams_tracks.html | Started Mon Nov 04 2013 17:57:39 GMT+0000 (GMT) (1383587859.772s)
17:58:13     INFO -  19016 INFO TEST-PASS | /tests/content/media/test/test_streams_tracks.html | [started big.wav-0] Length of array should match number of running tests
17:58:13     INFO -  19017 INFO TEST-PASS | /tests/content/media/test/test_streams_tracks.html | [started 320x240.ogv-1] Length of array should match number of running tests
17:58:13     INFO -  19018 INFO TEST-PASS | /tests/content/media/test/test_streams_tracks.html | Correct track count for http://mochi.test:8888/tests/content/media/test/big.wav
17:58:13     INFO -  19019 INFO TEST-PASS | /tests/content/media/test/test_streams_tracks.html | Correct track kind for track 0 of http://mochi.test:8888/tests/content/media/test/big.wav
17:58:13     INFO -  19020 INFO TEST-PASS | /tests/content/media/test/test_streams_tracks.html | id {d90c70a2-00b0-4924-9016-37aa0301a568} for track 0 of http://mochi.test:8888/tests/content/media/test/big.wav has correct form
17:58:13     INFO -  19021 INFO TEST-PASS | /tests/content/media/test/test_streams_tracks.html | Correct track count for http://mochi.test:8888/tests/content/media/test/big.wav
17:58:13     INFO -  19022 INFO TEST-PASS | /tests/content/media/test/test_streams_tracks.html | [finished big.wav-0] Length of array should match number of running tests
18:03:14     INFO -  19023 INFO TEST-PASS | /tests/content/media/test/test_streams_tracks.html | [started short-video.ogv-2] Length of array should match number of running tests
18:03:14     INFO -  19024 INFO TEST-PASS | /tests/content/media/test/test_streams_tracks.html | Correct track count for http://mochi.test:8888/tests/content/media/test/short-video.ogv
18:03:14     INFO -  19025 INFO TEST-PASS | /tests/content/media/test/test_streams_tracks.html | Correct track kind for track 0 of http://mochi.test:8888/tests/content/media/test/short-video.ogv
18:03:14     INFO -  19026 INFO TEST-PASS | /tests/content/media/test/test_streams_tracks.html | id {0fae4a64-0dff-4587-800c-6f45371600b5} for track 0 of http://mochi.test:8888/tests/content/media/test/short-video.ogv has correct form
18:03:14     INFO -  19027 INFO TEST-PASS | /tests/content/media/test/test_streams_tracks.html | Correct track count for http://mochi.test:8888/tests/content/media/test/short-video.ogv
18:03:14     INFO -  19028 INFO TEST-PASS | /tests/content/media/test/test_streams_tracks.html | Correct track kind for track 0 of http://mochi.test:8888/tests/content/media/test/short-video.ogv
18:03:14     INFO -  19029 INFO TEST-PASS | /tests/content/media/test/test_streams_tracks.html | id {839d4954-c153-4d8a-b0b8-eb23db8fd25f} for track 0 of http://mochi.test:8888/tests/content/media/test/short-video.ogv has correct form
18:03:14     INFO -  19030 INFO TEST-PASS | /tests/content/media/test/test_streams_tracks.html | [finished short-video.ogv-2] Length of array should match number of running tests
18:03:14     INFO -  19031 INFO TEST-PASS | /tests/content/media/test/test_streams_tracks.html | [started seek.webm-3] Length of array should match number of running tests
18:03:14     INFO -  19032 INFO TEST-PASS | /tests/content/media/test/test_streams_tracks.html | Correct track count for http://mochi.test:8888/tests/content/media/test/seek.webm
18:03:14     INFO -  19033 INFO TEST-PASS | /tests/content/media/test/test_streams_tracks.html | Correct track count for http://mochi.test:8888/tests/content/media/test/seek.webm
18:03:14     INFO -  19034 INFO TEST-PASS | /tests/content/media/test/test_streams_tracks.html | Correct track kind for track 0 of http://mochi.test:8888/tests/content/media/test/seek.webm
18:03:14     INFO -  19035 INFO TEST-PASS | /tests/content/media/test/test_streams_tracks.html | id {a862b4c0-7f6e-496a-8f8f-ad853ad8e328} for track 0 of http://mochi.test:8888/tests/content/media/test/seek.webm has correct form
18:03:14     INFO -  19036 INFO TEST-PASS | /tests/content/media/test/test_streams_tracks.html | [finished seek.webm-3] Length of array should match number of running tests
18:03:14     INFO -  19037 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_streams_tracks.html | Test timed out.
18:03:14     INFO -  19038 INFO TEST-END | /tests/content/media/test/test_streams_tracks.html | finished in 317122ms






So there's a five minute jump between these lines:
17:58:13     INFO -  19022 INFO TEST-PASS | /tests/content/media/test/test_streams_tracks.html | [finished big.wav-0] Length of array should match number of running tests
18:03:14     INFO -  19023 INFO TEST-PASS | /tests/content/media/test/test_streams_tracks.html | [started short-video.ogv-2] Length of array should match number of running tests
Assignee: nobody → jwwang
Attached patch part1_fix.patchSplinter Review
This is how it happens:

1. decoder state machine change state from DECODING to BUFFERING
2. all streams are blocked in media stream graph
3. decoder state machine change state from BUFFERING to DECODING
4. decoder tries to unblock the decoder stream
5. chances are media stream graph is woken up so soon that mCurrentTime barely advances that we end up having endBlockingDecisions == mStateComputedTime
6. Since stream blocking is computed in the interval of [mStateComputedTime, endBlockingDecisions), it won't be computed at all.
7. media stream graph goes into waiting indefinitely again for all streams are blocked

Fix: ensure next iteration when endBlockingDecisions == mStateComputedTime so that pending blocking changes will be recomputed.
Attachment #8385970 - Flags: review?(roc)
https://hg.mozilla.org/mozilla-central/rev/4da5d6fada69
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
Looking good here. Please request approval for aurora, beta, and b2g28 :)
Whoops, this doesn't need Aurora approval since it made it to m-c prior to the uplift on Monday :)
Flags: needinfo?(jwwang)
[Approval Request Comment]
Bug caused by (feature/regressing bug #): unknown
User impact if declined: media stream playback might get stuck
Testing completed (on m-c, etc.): try: https://tbpl.mozilla.org/?tree=Try&rev=1758e39cf243
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8395519 - Flags: review+
Attachment #8395519 - Flags: approval-mozilla-beta?
Flags: needinfo?(jwwang)
It looks like b2g28 now only allows patches about security.
Attachment #8395519 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Comment on attachment 8395519 [details] [diff] [review]
part1_fix_beta.patch

(In reply to JW Wang[:jwwang] from comment #19)
> It looks like b2g28 now only allows patches about security.

See https://wiki.mozilla.org/Release_Management/B2G_Landing#v1.3.0

[Approval Request Comment]
Bug caused by (feature/regressing bug #): unknown
User impact if declined: media stream playback might get stuck and likely test disabling
Testing completed (on m-c, etc.): try: https://tbpl.mozilla.org/?tree=Try&rev=1758e39cf243 - landed on m-c/aurora and about to land on beta
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8395519 - Flags: approval-mozilla-b2g28?
Attachment #8395519 - Flags: approval-mozilla-b2g28? → approval-mozilla-b2g28+
Blocks: 975092
You need to log in before you can comment on or make changes to this bug.