Clicking link w/ menu open does nothing, should go to link.

RESOLVED DUPLICATE of bug 21390

Status

--
trivial
RESOLVED DUPLICATE of bug 21390
18 years ago
14 years ago

People

(Reporter: renzys, Assigned: asa)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.3) Gecko/20010801
BuildID:    2001080110

Hello,

Please forgive my stupidity if I am not using the system correctly, as this is
the first time I've reported a "bug."

When a menu in the Mozilla browser is open, e.g. the File menu, clicking a link
on the currently open page closes the menu, but does not go to the link.

This action is counter intuitive, because when the cursor passes over the link,
even with the menu open, it changes to the pointing hand.  This cursor is used
at other times to indicate the link may be clicked on, but, with the menu open,
it does nothing.

I propose one of two solutions:
- Don't change the cursor to the hand as it passes over a link with a menu open.
 This would indicate to the user that clicking the link would not actually go
there. OR...
- Keep the hand, but instead of simply closing the menu, make clicking the link
actually go there AND close the menu.

Reproducible: Always
Steps to Reproduce:
1. Open a menu in the mozilla browser, for instance, the file menu.
2. With the menu open, click a link on the page, any link.


Actual Results:  The menu is closed.

Expected Results:  The menu is closed, and the browser navigates to the link.

Comment 1

18 years ago
Reporter, looks like you're using the system just fine.  Unfortunately, this is
a duplicate of an existing bug that was marked invalid.



*** This bug has been marked as a duplicate of 21390 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.