Closed Bug 934988 Opened 6 years ago Closed 6 years ago

Australis menu still consumes clicks outside it

Categories

(Firefox :: Menus, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 28

People

(Reporter: ge3k0s, Assigned: dao)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:M9][Australis:P3])

Attachments

(1 file)

Since bug 596723 landed, the clicks outside panels aren't consumed anymore. That feels much more natural. The Australis panel menu however still consumes the clicks outside it. It's a bit annoying and it's not consistent with other panels behaviour.
Whiteboard: [Australis:M?][Australis:P3]
Summary: Australis menu still consumes click outside it → Australis menu still consumes clicks outside it
(In reply to Guillaume C. [:ge3k0s] from comment #1)
> Since bug 596723 landed, the clicks outside panels aren't consumed anymore.
> That feels much more natural. The Australis panel menu however still
> consumes the clicks outside it. It's a bit annoying and it's not consistent
> with other panels behaviour.

Can you be more explicit about what the problematic behaviour is and what you want to see instead?
I don't know exactly how to explain it. It's clearly a follow-up from bug 596723. Before it landed, when you had a panel opened and for example clicked on a link on the page, first the panel was dismissed and then you had to click a second time to open the link. Now with bug 596723 resolved, you can directly access to the link by clicking on it. It works with every panel except the Australis menu. I hope it's more clear now.
That's because we explicitly set it to true in http://hg.mozilla.org/projects/ux/rev/d92bea85aa14 - bug 870897. Paging Mike, Mike and Blair to figure out why.
Flags: needinfo?(mdeboer)
(In reply to :Gijs Kruitbosch from comment #3)
> That's because we explicitly set it to true in
> http://hg.mozilla.org/projects/ux/rev/d92bea85aa14 - bug 870897. Paging
> Mike, Mike and Blair to figure out why.

You're talking about consumeoutsideclicks="true"? That patch didn't change that.
Blocks: 596723
After some testing, it appears that this is indeed not necessary anymore; the zoom and edit controls still function correctly without `consumeoutsideclicks="true"` on the most recent build(s).
But Dão's right: http://hg.mozilla.org/projects/ux/rev/f7cb839f3bfc added it.

So this is still one for mconley to answer.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(mdeboer)
http://hg.mozilla.org/projects/ux/rev/f7cb839f3bfc simply predates bug 596723, so consumeoutsideclicks="true" was necessary just like for all other arrow panels.
Flags: needinfo?(mconley)
Attached patch patchSplinter Review
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #827442 - Flags: review?(mconley)
(In reply to Dão Gottwald [:dao] from comment #7)
> http://hg.mozilla.org/projects/ux/rev/f7cb839f3bfc simply predates bug
> 596723, so consumeoutsideclicks="true" was necessary just like for all other
> arrow panels.

I'll be honest and say that it's been too long since I wrote that code to know why I put it there, but I trust Dao's read on the matter.
http://hg.mozilla.org/projects/ux/rev/111df3321032
No longer blocks: 596723
Depends on: 596723
Whiteboard: [Australis:M?][Australis:P3] → [Australis:M9][Australis:P3][fixed-in-ux]
https://hg.mozilla.org/mozilla-central/rev/111df3321032
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:M9][Australis:P3][fixed-in-ux] → [Australis:M9][Australis:P3]
Target Milestone: --- → Firefox 28
You need to log in before you can comment on or make changes to this bug.