auto-closing DT/DD doesn't work

VERIFIED DUPLICATE of bug 1346

Status

()

P2
normal
VERIFIED DUPLICATE of bug 1346
20 years ago
15 years ago

People

(Reporter: kipp, Assigned: rickg)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
According to the HTML4 DTD, the end tags for DT and DD tags are optional.
Therefore the
following html should be legal:

<HTML>
<STYLE>
</STYLE>
<BODY>
Before the DL
<DL>
 <DT>Dee-tee
 <DD>Dee-dee
 <DT>Dee-tee #2
 <DD>Dee-dee #2
</DL>
After the DL
</BODY>
</HTML>

However, your parser creates the following (incorrect) content tree:

HTML refcount=4<
  HEAD refcount=2<
  >
  BODY refcount=4<
    Text refcount=3<\nBefore the DL\n>
    DL refcount=3<
      Text refcount=3<\n >
      DT refcount=3<
        Text refcount=3<Dee-tee\n >
        DD refcount=3<
          Text refcount=3<Dee-dee\n >
        >
        DT refcount=3<
          Text refcount=3<Dee-tee #2\n >
          DD refcount=3<
            Text refcount=3<Dee-dee #2\n>
          >
        >
      >
    >
    Text refcount=3<\nAfter the DL\n\n\n>
  >
>
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 1

20 years ago
They do now.
Resolution: FIXED → ---
This is broken again (as of 11/9).  See near the bottom of the above URL.  It
was fixed at one point (I only checked 10/15 but I have a bunch in between).
Status: REOPENED → RESOLVED
Last Resolved: 20 years ago20 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 1346 ***

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 4

20 years ago
Marking Verified/Duplicate.
You need to log in before you can comment on or make changes to this bug.