Refuse to mark duplicate if reporter can't see duplicate

RESOLVED DUPLICATE of bug 96085

Status

()

Bugzilla
Creating/Changing Bugs
P3
normal
RESOLVED DUPLICATE of bug 96085
16 years ago
13 years ago

People

(Reporter: Stephen Rasku, Unassigned)

Tracking

Details

(Reporter)

Description

16 years ago
Currently, if you mark a bug a duplicate of another bug, the reporter is CCed
onto the original bug.  However, it is possible for the original bug to have
permissions that down't allow the reporter see it.  In this case, it should
refuse to mark it a duplicate with an error message (e.g. "Reporter cannot see
original bug -- please fix permissions on original bug").
see also bug 39816.  But I'll leave this because I think it still ought to 
provide some appropriate warning...
Priority: -- → P3
Target Milestone: --- → Bugzilla 2.16
I think one of the major problems is if the resolved bug has a groupset that
isn't a superset of the open bug, regardless of the reporter.  A whole lot of
people couldn't see the bug then.
Component: Bugzilla → Creating/Changing Bugs
Product: Webtools → Bugzilla
Version: Bugzilla 2.12 → 2.12
This was sort of fixed by my patch for bug 96085 which made it into 2.14. 
Instead of outright refusing it though, the person duping the bug is given a
choice if they can see it.
That fix only handles the situation for the reporter.

If the groupset isnt a subset of the original bug's groupset, I think it should
still give a warning, because the reporter isn't the only relevant person.
We are currently trying to wrap up Bugzilla 2.16.  We are now close enough to
release time that anything that wasn't already ranked at P1 isn't going to make
the cut.  Thus this is being retargetted at 2.18.  If you strongly disagree with
this retargetting, please comment, however, be aware that we only have about 2
weeks left to review and test anything at this point, and we intend to devote
this time to the remaining bugs that were designated as release blockers.
Target Milestone: Bugzilla 2.16 → Bugzilla 2.18
But the reporter is the only one who can see the other bug, if they're added to
the cc. The duper has to be able to see it, after that fix went in.
so this is either FIXED, a dupe, or INVALID, depending on which of the points we
take. I think.

Comment 8

14 years ago
Unloved bugs targetted for 2.18 but untouched since 9-15-2003 are being
retargeted to 2.20
If you plan to act on one immediately, go ahead and pull it back to 2.18.
Target Milestone: Bugzilla 2.18 → Bugzilla 2.20
*** Bug 131695 has been marked as a duplicate of this bug. ***

Comment 10

13 years ago
This bug has not been touched by its owner in over six months, even though it is
targeted to 2.20, for which the freeze is 10 days away. Unsetting the target
milestone, on the assumption that nobody is actually working on it or has any
plans to soon.

If you are the owner, and you plan to work on the bug, please give it a real
target milestone. If you are the owner, and you do *not* plan to work on it,
please reassign it to nobody@bugzilla.org or a .bugs component owner. If you are
*anybody*, and you get this comment, and *you* plan to work on the bug, please
reassign it to yourself if you have the ability.
Target Milestone: Bugzilla 2.20 → ---
Reassigning bugs that I'm not actively working on to the default component owner
in order to try to make some sanity out of my personal buglist.  This doesn't
mean the bug isn't being dealt with, just that I'm not the one doing it.  If you
are dealing with this bug, please assign it to yourself.
Assignee: justdave → create-and-change
QA Contact: mattyt-bugzilla → default-qa

*** This bug has been marked as a duplicate of 96085 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.