Closed Bug 935109 Opened 6 years ago Closed 6 years ago

Loader changes to support node dependencies

Categories

(Add-on SDK Graveyard :: General, defect, P1)

x86
macOS
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jsantell, Assigned: jsantell)

References

Details

Attachments

(1 file)

https://github.com/mozilla/addon-sdk/pull/1279

The loader change would be a change to how files are resolved when using Jetpack's require to accomodate node modules.
No longer depends on: nodeification
Blocks: 949088
Attached file GH PR 1291
Tests are passing, everything behind a flag, so this should be able to land to ease AOM migrations, as we optimize and continue to work behind a 'native' flag until we're ready to roll out.

Give a close eye to the components in sdk/test/ and things outside of toolkit/loader mainly
Attachment #8346279 - Flags: review?(evold)
Duplicate of this bug: 922308
(In reply to Jordan Santell [:jsantell] [@jsantell] from comment #0)
> https://github.com/mozilla/addon-sdk/pull/1279
> 
> The loader change would be a change to how files are resolved when using
> Jetpack's require to accomodate node modules.

Oops I reviewed this JEP, we should complete this and land it first.
Comment on attachment 8346279 [details]
GH PR 1291

Nice work! this is awesome :)

I just mentioned some tests that should be included in the merge.
Attachment #8346279 - Flags: review?(evold) → review+
We can make the // issue a separate bug.
Commits pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/3781fecb520e5c7fbe10ec2e89efd861467ef64c
Bug 935109 - Implement native loader capable of loading node-style
dependencies

https://github.com/mozilla/addon-sdk/commit/d7af5ad3e6a05bccec0bb3f370f48e9a7c8d7bae
Merge pull request #1291 from jsantell/nodeloader-imp

Bug 935109 Native Node Loader Implementation, r=@erikvold
Merged
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 638249
No longer blocks: 903039
You need to log in before you can comment on or make changes to this bug.