[B2G][Clock][Alarm]Digital display of “X:44” minutes clips due to spacing between the 4’s.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: pbylenga, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g18 unaffected, b2g-v1.2 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 827691 [details]
ClockAppDigital44.png

Description:
When time is at the 44th minute, regardless of hour, the text “44” clips itself due to a spacing issue.

Repro Steps:
1) Updated Buri to Build ID: 20131105004003
2) Navigate to Settings: Date & Time and set time to 12:44.
3) Navigate to Homescreen and launch Clock App.
4) Switch to digital clock on Alarm screen and observe Time text.

Actual:
The 4’s clip each other due to spacing.

Expected:
The 4’s are naturally spaced to avoid clipping.

Environmental Variables
Device: Buri v1.2 COM RIL
Build ID: 20131105004003
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/3ba912717904
Gaia: be4ea00a50236b10eb0a03232a28ffd0048e0cb8
Platform Version: 26.0
RIL Version: 01.01.00.019.281 
Firmware Version: US_20131015

Notes:
Repro frequency: 5/5, 100%
See attached: screenshot
(Reporter)

Comment 1

5 years ago
Issue does not repro on Leo 1.1

Environmental Variables
Device: Leo v 1.1.0 COM RIL
Build ID: 20131030041204
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/41c15ddb7216
Gaia: 39b0203fa9809052c8c4d4332fef03bbaf0426fc
Platform Version: 18.1
RIL Version: 01.01.00.019.264
status-b2g18: --- → unaffected
Polish issue, not worth getting a window on.
Keywords: regressionwindow-wanted
Can you take another look on master/1.4? There is now a (very small) space between the 4's.
Flags: needinfo?(pbylenga)
(Reporter)

Comment 4

5 years ago
Created attachment 8358483 [details]
Updated_Clock_Time_44_Master.png

I can confirm there is a small space now between ":44".

Environmental Variables
Device: Buri Master(1.4) Mozilla RIL
Build ID: 20140110040206
Gecko: http://hg.mozilla.org/mozilla-central/rev/37516445a0b5
Gaia: f400efc804366c7b7cf5476d1d5d325e6651ee71
Platform Version: 29.0a1
Firmware Version: 20131115
Flags: needinfo?(pbylenga)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.