Closed Bug 935370 Opened 6 years ago Closed 6 years ago

Inline all Pod functions

Categories

(Core :: MFBT, defect, minor)

defect
Not set
minor

Tracking

()

RESOLVED FIXED
mozilla28
Tracking Status
firefox27 --- fixed
firefox28 --- fixed

People

(Reporter: cpeterson, Assigned: cpeterson)

References

Details

(Whiteboard: [qa-])

Attachments

(1 file)

Is there a reason why some of the Pod template functions are `MOZ_ALWAYS_INLINE static` and others are just `static`? These functions were all `JS_ALWAYS_INLINE static` in jsutils.h.
Attachment #827813 - Flags: review?(jwalden+bmo)
Comment on attachment 827813 [details] [diff] [review]
inline-pod-functions.patch

Review of attachment 827813 [details] [diff] [review]:
-----------------------------------------------------------------

Not sure why it's this way, offhand.  As a nitpick, I'd prefer the order be |static MOZ_ALWAYS_INLINE| rather than the reverse.  (And I'd rather see inline than MOZ_ALWAYS_INLINE, as the latter suggests we've really inspected uses and know that inline is *always* what we want, but that's not necessarily the case for all of these.)
Attachment #827813 - Flags: review?(jwalden+bmo) → review+
(In reply to Jeff Walden [:Waldo] (remove +bmo to email) from comment #1)
> As a nitpick, I'd prefer the order be |static MOZ_ALWAYS_INLINE| rather than the reverse.

I agree; I was just following the style of the other template functions in PodOperations.h.
https://hg.mozilla.org/mozilla-central/rev/23aa24fa8d20
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
Comment on attachment 827813 [details] [diff] [review]
inline-pod-functions.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 856850 (Firefox 23)
User impact if declined: Negligible code size difference.
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): Very low risk. These functions used to be inline, but some of the `inline` keywords were not copied when these functions were moved from the jsutils.h header file to PodOperations.h.
String or IDL/UUID changes made by this patch: N/A
Attachment #827813 - Flags: approval-mozilla-aurora?
Attachment #827813 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.