All users were logged out of Bugzilla on October 13th, 2018

metacafe.com sends desktop version of site

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: hsteen, Assigned: adamopenweb)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mobile-compat-form][serversniff][sitewait] [country-us], URL)

(Reporter)

Description

5 years ago
Site: http://www.metacafe.com
metacafe.com sends desktop version of site

:: Steps To Reproduce

Server-side browser sniffing customizes the content sent from the metacafe.com URL. With "Android" in UA string we get a mobile, without a desktop site. (Luckily, videos play fine anyway)

:: Expected Result

Mobile site

:: Actual Result

desktop site

:: Additional Information

Software Version: 1.1
Reporter's User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:25.0) Gecko/20100101 Firefox/25.0
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [mobile-compat-form] → [mobile-compat-form][serversniff][contactready]

Updated

5 years ago
Whiteboard: [mobile-compat-form][serversniff][contactready] → [mobile-compat-form][serversniff][contactready] [country-us]
(Assignee)

Updated

5 years ago
Assignee: nobody → astevenson
(Assignee)

Comment 1

5 years ago
Contacted via form on site.

I'm working at Mozilla to solve Web Compatibility issues. I'm reporting an issue about your Web site not working properly with Firefox OS (Mozilla). This affects the following site:
 
         http://www.metacafe.com
 
Could you put me in contact with the right person in the Communications/Marketing team and/or Technical team in charge of your Web site?
 
The issue is described in detail on the Mozilla bug tracker: https://bugzilla.mozilla.org/show_bug.cgi?id=935475
Status: NEW → ASSIGNED
Whiteboard: [mobile-compat-form][serversniff][contactready] [country-us] → [mobile-compat-form][serversniff][sitewait] [country-us]
(Assignee)

Comment 2

5 years ago
No response, trying Twitter.
(Assignee)

Comment 3

5 years ago
Emailing support@metacafe.com.

Comment 4

5 years ago
Adam, 

metacafe belongs to Digital Collective Studios.

A human contact may help, maybe it will work better.
http://www.linkedin.com/in/markheyert1
https://twitter.com/markhhsp

Comment 6

5 years ago
Hey guys, I'm Mike Flynn, VP of Tech @ Collective Digital Studio / Metacafe. Looks like we need to add a string to Metacafe's mobile discovery code?
(Assignee)

Comment 7

5 years ago
Hi Mike! Thanks for the quick response. Yes Firefox OS is not being detected as a mobile browser. The user agent string looks something like: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0 and the recommended way to detect is by searching for the string "Mobi". If you need any help let us know.

https://developer.mozilla.org/en-US/docs/Browser_detection_using_the_user_agent#OS

Comment 8

5 years ago
No problem, I'll dive in track this down ASAP.

I'll confirm back on this thread once we've released the change.

Comment 9

5 years ago
Just deployed a change, and you now get the mobile experience when you have a user agent like the example above.

If there's anything else you need, feel free to shoot me an email or hit me up on Twitter directly: @mikeflynn_
(Assignee)

Comment 10

5 years ago
Wow that was fast. I'm getting the mobile site on both my devices. Thanks for the help Mike, we really appreciate it!
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 11

5 years ago
No problem at all! We're pretty quick around here! 

...now I just need to get a Firefox OS phone to play with!
(In reply to Mike Flynn from comment #11)
> ...now I just need to get a Firefox OS phone to play with!

:) A few suggestions:

* in Firefox Web Developer Tools (Menu Tools -> Web Developer -> App Manager)
  At the bottom there is "Start Simulator" (you might have to install a package for the first time)
  It creates a window for testing sites and apps.
  https://developer.mozilla.org/en-US/docs/Tools/Firefox_OS_Simulator

* For actual devices.
  Countries and availability
  https://www.mozilla.org/en-US/firefox/os/devices/
  Developer device coming soon
  https://developer.mozilla.org/en-US/Firefox_OS/Developer_phone_guide/Flame
You need to log in before you can comment on or make changes to this bug.