Closed Bug 935561 Opened 6 years ago Closed 6 years ago

[Messaging] Attach icon is kept like pressed when tapping on it and cancel selecting a content to attach

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3+)

VERIFIED FIXED
1.3 Sprint 6 - 12/6
blocking-b2g 1.3+

People

(Reporter: isabelrios, Assigned: vingtetun)

Details

(Keywords: regression)

Attachments

(3 files, 2 obsolete files)

Attached image Attach icon
master 11/06 build:
Gecko-e612f4f
Gaia-b12d548

STR
1. Open messaging app and create a new message
2. Tap on attach icon
3. Tap on Cancel on the menue Select from

EXPECTED
The button should be disabled when coming back from other menu

ACTUAL
The button is kept like active. Please see screenshot attached.
I think this is because a recent Gecko change with focus and hover styles.

Vivien, I think that you know more, especially maybe a bug number and a suggested fix?
Flags: needinfo?(21)
triage: regresssion. 1.3+
blocking-b2g: 1.3? → 1.3+
Keywords: regression
Can someone check if this reproduces on 1.2?
Keywords: qawanted
Attached patch bug935561.patch (obsolete) — Splinter Review
Attachment #832250 - Flags: review?(fabrice)
Flags: needinfo?(21)
Attached patch bug935561.patch (obsolete) — Splinter Review
I have a bit weird configuration on my phone and this stuff was preventing me to have a menu while clicking on the sms button.
Attachment #832253 - Flags: review?(fabrice)
Attached patch bug935561.patchSplinter Review
I forgot to qrefresh...
Attachment #832250 - Attachment is obsolete: true
Attachment #832250 - Flags: review?(fabrice)
Attachment #832315 - Flags: review?(fabrice)
Attachment #832253 - Flags: review?(fabrice)
Attachment #832253 - Attachment is obsolete: true
Attachment #832315 - Flags: review?(fabrice) → review+
(In reply to Jason Smith [:jsmith] from comment #3)
> Can someone check if this reproduces on 1.2?

Cannot reproduce this on v1.2 (11/18 build):
Gecko-1443247
Gaia-7a23f8c

Removing qawanted
Keywords: qawanted
Seems the qawanted did not get removed properly, removing qawanted per Comment 7.
Keywords: qawanted
Vivien: since you already provided a patch. assign this bug to you for now.
Assignee: nobody → 21
Target Milestone: --- → 1.3 Sprint 6 - 12/6
https://hg.mozilla.org/mozilla-central/rev/8c65b69f6d5f
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Checked with today's master build (11/25):
Gecko-35d902d
Gaia-c736d91

The icon is still seen as tapped, please see screenshot attached. 
Could that be that the patch has not landed or should the bug be re-opened?
Hey Vivien,

looks like this bug is not fixed?
Flags: needinfo?(21)
(In reply to Julien Wajsberg [:julienw] from comment #14)
> Hey Vivien,
> 
> looks like this bug is not fixed?

Sigh. I have landed the patch I made before the qrefresh...
Flags: needinfo?(21)
(In reply to Vivien Nicolas (:vingtetun) (:21) (RTO - Review Time Off until 09/12/13) from comment #15)
> (In reply to Julien Wajsberg [:julienw] from comment #14)
> > Hey Vivien,
> > 
> > looks like this bug is not fixed?
> 
> Sigh. I have landed the patch I made before the qrefresh...

I will push the missing part as soon the tree is reopened.
https://hg.mozilla.org/integration/mozilla-inbound/rev/02c588356f49

The missing part. Sigh.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
https://hg.mozilla.org/mozilla-central/rev/02c588356f49
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Now it is working fine. 
Checked with 04/12  master build:
Gecko-2dc4d2d
Gaia-573304f.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.