Closed Bug 935596 Opened 7 years ago Closed 7 years ago

nsJARInputStream crashes debug builds when it encounters a corrupt zip file

Categories

(Core :: Networking: JAR, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla28
Tracking Status
firefox27 --- fixed
firefox28 --- fixed

People

(Reporter: mossop, Assigned: mossop)

References

Details

(Whiteboard: [qa-])

Attachments

(1 file)

If the CRC check fails it asserts.
Attached patch patchSplinter Review
I don't think there is any reason to break in debug builds for this case, we don't for other cases of zip corruption like bad central directory structures.
Attachment #828336 - Flags: review?(taras.mozilla)
Attachment #828336 - Flags: review?(taras.mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/85cc576fc376
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
Comment on attachment 828336 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): N/A
User impact if declined: We can't land the test for bug 932361
Testing completed (on m-c, etc.): Multiple days on m-c
Risk to taking this patch (and alternatives if risky): No risk, this is a debug build only change
String or IDL/UUID changes made by this patch: None
Attachment #828336 - Flags: approval-mozilla-aurora?
Attachment #828336 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.