[B2G][Browser][Text Field]Unable to scroll when text input exceeds text window size.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: rkuhlman, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(b2g-v1.4 affected)

Details

(Whiteboard: burirun1.3-1, burirun1-4.1)

Attachments

(1 attachment)

Created attachment 828332 [details]
User types text into google search bar, attempts to scroll through text

Description:
If the text in a text field exceeds the size of the field, the user should be able to scroll through the text in order to check their input. The user cannot scroll through text in a text field.

Repro Steps:
1) Updated Buri/Inari/Leo/Unagi to Build ID: 20131106004004
2) Navigate to www.google.com.
3) Enter text into the search bar until the amount of text exceeds the available screen space.
4) Tap in another field.
5. Tap back on the original field and use your finger to scroll to the right.

Actual:
User is unable to scroll text.

Expected:
User can scroll left/right in order to view all text entered into the text field.

Environmental Variables
Device: Buri v 1.2 MOZ RIL
Build ID: 20131106004004
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/6a831fcb96f4
Gaia: 2140c987fdde1c99097018f7e93b0bbd43d2125d
Platform Version: 26.0
RIL Version: 01.01.00.019.281 
Firmware Version: US_20131015

Notes:
Repro frequency: 7/7 100%
Test Suite Name: Browser
Link to failed test case: https://moztrap.mozilla.org/manage/case/3564/
See attached: logcat
Issue also occurs in 1.1.

This issue has occurred and been resolved previously.
https://bugzilla.mozilla.org/show_bug.cgi?id=817845
Component: Gaia::Browser → Panning and Zooming
Product: Firefox OS → Core

Updated

5 years ago
Whiteboard: burirun1.3-1
qawanted to retest. This should have been fixed by bug 946408 in 1.3 and up.
Keywords: qawanted
status-b2g-v1.4: --- → affected
Whiteboard: burirun1.3-1 → burirun1.3-1, burirun1-4.1
This works for me now. As long as the input field has focus, I can scroll it. If the focus is completely removed from the input field then it cannot be scrolled (this is by design).

Please reopen if you are still able to reproduce.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.