Closed Bug 935792 Opened 7 years ago Closed 7 years ago

ignoreAbsent flag for removeDir() doesn't default to true as intended/documented

Categories

(Toolkit :: OS.File, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla28

People

(Reporter: Unfocused, Assigned: Yoric)

References

Details

(Keywords: addon-compat)

Attachments

(1 file)

Seems the ignoreAbsent flag for removeDir() was intended to default to true, to match remove(). Looking at the code/test, it seems to default to false.
Assignee: nobody → dteller
Attachment #8337461 - Flags: review?(nfroyd)
Attachment #8337461 - Flags: review?(nfroyd) → review+
https://hg.mozilla.org/integration/fx-team/rev/7e551a8edbb7
Flags: in-testsuite+
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/7e551a8edbb7
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → mozilla28
You need to log in before you can comment on or make changes to this bug.