Closed Bug 935898 Opened 6 years ago Closed 2 years ago

usopen.org sends desktop content to FirefoxOS

Categories

(Web Compatibility :: Mobile, defect, P5)

Other
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: hsteen, Assigned: adamopenweb)

References

()

Details

(Whiteboard: [mobile-compat-form][serversniff][needscontact] [country-us])

Site: http://usopen.org
usopen.org sends desktop content to FirefoxOS

:: Steps To Reproduce

server-side sniffing redirects to /mobile/en_US/index.html - would work fine in Firefox OS  too.

:: Expected Result

mobile content and video

:: Actual Result

no mobile content

:: Additional Information

Software Version: 1.1
Reporter's User Agent: Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [mobile-compat-form] → [mobile-compat-form][serversniff][contactready]
Whiteboard: [mobile-compat-form][serversniff][contactready] → [mobile-compat-form][serversniff][contactready] [country-us]
Seems to be fixed on its own. Tested in simulator and on a device, redirects to the mobile site.

http -b GET http://usopen.org/ User-Agent:'Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0'

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>301 Moved Permanently</title>
</head><body>
<h1>Moved Permanently</h1>
<p>The document has moved <a href="http://www.usopen.org/">here</a>.</p>
<hr>
<address>IBM_HTTP_Server at usopen.org Port 80</address>
</body></html>
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Thanks adam!
This is fixed indeed.

Btw the first redirect you show in the previous comment is from usopen.org to www.usopen.org
The next one will be for mobile.

→ http --print hH GET http://www.usopen.org/ User-Agent:'Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0'
GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.usopen.org
User-Agent: Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 302 Moved Temporarily
Cache-Control: private, s-maxage=0, no-cache, no-store, must-revalidate
Connection: keep-alive
Content-Length: 58830
Content-Type: text/html; charset=utf-8
Date: Tue, 07 Jan 2014 00:46:13 GMT
Expires: Sat, 12 Jan 2013 00:46:13 GMT
Location: http://www.usopen.org/mobile/
Pragma: no-cache
Server: Microsoft-IIS/6.0
X-AspNet-Version: 2.0.50727
X-Powered-By: ASP.NET
Status: RESOLVED → VERIFIED
Assignee: nobody → astevenson
Regressed - Firefox OS gets a desktop site again.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Whiteboard: [mobile-compat-form][serversniff][contactready] [country-us] → [mobile-compat-form][serversniff][needscontact] [country-us]
Status: REOPENED → NEW
Priority: -- → P5
I don't think we are going to work on this anymore, closing.
Status: NEW → RESOLVED
Closed: 6 years ago2 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.