Closed Bug 935904 Opened 6 years ago Closed 6 years ago

Intermittent Travis Unit test failure: [system] KeyboardManager Transitions UpdateHeight waits until transition finished: Error: timeout of 2000ms exceeded

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 936369

People

(Reporter: julienw, Assigned: janjongboom)

Details

(Keywords: intermittent-failure)

1) [system] KeyboardManager Transitions UpdateHeight waits until transition finished:

Error: timeout of 2000ms exceeded

See also bug 936369 and bug 936011.
Marked the test as intermittent in https://github.com/mozilla-b2g/gaia/commit/bf76f13020d638158a9a7ac5d0a5fe4f0e19a1de

Jan: Git blame says you are the author of this test. Would you mind taking a look?
Assignee: nobody → janjongboom
Travis passes against this test again https://travis-ci.org/mozilla-b2g/gaia/builds/14807488

So enabled it. https://github.com/mozilla-b2g/gaia/commit/5684cd760e1644138cbe4733277b3ae442a9bda3
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
jan, that's what Intermittent means: sometimes it passes, sometimes it won't.

You need to make the code more synchronous. For example, you could dispatch the transitionend event in the unit test yourself, to trigger the code running.
Rik, should we reopen this?
Flags: needinfo?(anthony)
Oops. :p
Reverted in https://github.com/mozilla-b2g/gaia/commit/3a070d5a406a4ae1f3d3f5208bc23bef31cd9f83
Status: RESOLVED → REOPENED
Flags: needinfo?(anthony)
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 936369
You need to log in before you can comment on or make changes to this bug.