All users were logged out of Bugzilla on October 13th, 2018

[wasabi] When switch network type from CDMA to EVDO, 1x icon with no level signal bar will show for a while. (EVDO to CDMA has the same problem)

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
8 months ago

People

(Reporter: echu, Unassigned)

Tracking

unspecified
x86_64
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
Created attachment 828624 [details]
Time stamp 11:14(CDMA > EVDO), 11:15(EVDO > CDMA)

When change network type form CDMA to EVDO, RSSI shows no signal bar with 1x next to it, which means 1x data call is connected but with no signal which is very strange behavior. Even EV is no connected yet, there should still have 1x signal, not completely no signal at all.

Gaia:     2db8490d5c1d7eeab8f7383042616a0391571501
Gecko:    8ba2d299b4b5da1c9290d8e0c4e8f47820c5cd1a
BuildID   20131107031537
Version   26.0

* Reproduce Steps
1. Set CDMA as network type.
2. Make sure 1x data call is established, and there is signal.
3. Change network type to EVDO.

* Expected Result
Before EV is connected, if 1x data call is still connected, there should have 1x icon next to signal bar with levels.

* Actual Result
RSSI change to 1x with no signal status right away.

* Occurrence rate
100%
(Reporter)

Comment 1

5 years ago
Earlier the day log has been sent to Edgar and there is first conclusion that modem report null signal which cause the problem, so label POVB for this bug first.

// switch to evdo only
11-07 11:13:56.323 I/Gecko   (  201): -*- RadioInterface[0]: 'ril.radio.preferredNetworkType' is now evdo
11-07 11:13:56.393 I/Gecko   (  201): -*- RadioInterface[0]: _preferredNetworkType is now evdo

// modem still report data call is established and the type is '1xrtt'
11-07 11:13:56.973 I/Gecko   (  674): -*- RILContentHelper: Received message 'RIL:DataInfoChanged': {"clientId":0,"data":{"connected":true,"emergencyCallsOnly":false,"roaming":false,"network":{"longName":null,"shortName":null,"mcc":null,"mnc":null},"cell":{"gsmLocationAreaCode":-1,"gsmCellId":-1},"type":"1xrtt","signalStrength":null,"relSignalStrength":null,"state":"registered","apn":"aptnet"}}
Whiteboard: [FT:RIL, POVB]
Created attachment 8335937 [details]
qcril_adblogcat.log

QCRIL does not have this problem. Test build: 20131120031537

Please see attached adb logcat file.

Test start: 11-21 18:20:56.176

1. Automatic -> CDMA
   1X appears at 11-21 18:21:44.218 

2. CDMA->EVDO
   EV appears: 11-21 18:22:19.330

3. EVDO -> CDMA
   1X appears: 11-21 18:23:13.397

4. CDMA -> Automatic
   EV appears: 11-21 18:23:49.255
(Reporter)

Comment 3

5 years ago
Remove POVB from whiteboard since QCRIL has not such bug.
Whiteboard: [FT:RIL, POVB] → [FT:RIL]
The behavior with QCRIL is:
1. Set CDMA as network type.
2. Make sure 1x data call is established, and there is signal.
3. Change network type to EVDO.

* Test Result
1x icon next to signal bar with levels become EV icon very quickly. And EV signal is used for data call.

Comment 5

5 years ago
Edgar, we should add have a solution here.thanks
Assignee: nobody → echen

Updated

5 years ago
Attachment #8335937 - Attachment mime type: text/x-log → text/plain

Comment 6

5 years ago
Checking the log again (attachment 828624 [details]), 

// After switching preferred type.
11-07 11:13:56.393 I/Gecko   (  201): -*- RadioInterface[0]: _preferredNetworkType is now evdo

// Modem report invalid signal strength for a while.
11-07 11:13:56.963 I/Gecko   (  201): RIL Worker[0]: signal strength: {"gsmSignalStrength":0,"gsmBitErrorRate":0,"cdmaDBM":0,"cdmaECIO":0,"evdoDBM":0,"evdoECIO":0,"evdoSNR":0,"lteSignalStrength":0,"lteRSRP":0,"lteRSRQ":0,"lteRSSNR":0,"lteCQI":0}
11-07 11:13:57.624 I/Gecko   (  201): RIL Worker[0]: signal strength: {"gsmSignalStrength":0,"gsmBitErrorRate":0,"cdmaDBM":0,"cdmaECIO":0,"evdoDBM":0,"evdoECIO":0,"evdoSNR":0,"lteSignalStrength":0,"lteRSRP":0,"lteRSRQ":0,"lteRSSNR":0,"lteCQI":0}

// After a while, finally modem report correct signal information.
11-07 11:14:03.073 I/Gecko   (  201): RIL Worker[0]: $$signal strength: {"gsmSignalStrength":99,"gsmBitErrorRate":0,"cdmaDBM":-1,"cdmaECIO":-1,"evdoDBM":58,"evdoECIO":5,"evdoSNR":6,"lteSignalStrength":99,"lteRSRP":2147483647,"lteRSRQ":2147483647,"lteRSSNR":2147483647,"lteCQI":2147483647}

It seems modem's issue, I guess COMRIL did some workaround for this.

Comment 7

5 years ago
Hi Peipei,

Could you capture log again with radio log enabled by "adb logcat -v threadtime -b radio -b main" for both MOZ_RIL and COM_RIL? Maybe we can find some clues from them.

BTW, if you can test them side by side, it will be great.

Thank you
Flags: needinfo?(pcheng)
Created attachment 8342836 [details]
COM_RIL.log

Sorry I could not reproduce them side by side since I only have one device for test.

CDMA -> EVDO : 12-05 11:27:33.613
EVDO -> CDMA : 12-05 11:29:00.058
Flags: needinfo?(pcheng)
Created attachment 8342837 [details]
MOZ_RIL.log

CDMA -> EVDO: 12-05 11:39:35.457
EVDO -> CDMA: 12-05 11:40:12.586
Whiteboard: [FT:RIL]

Updated

5 years ago
blocking-b2g: --- → backlog
blocking-b2g: backlog → -

Updated

3 years ago
Assignee: echen → nobody

Comment 10

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.