[fugu]the camera app can not take picture in the dark environment

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: Dafeng.Xu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 829098 [details] [diff] [review]
camera.patch

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.22 (KHTML, like Gecko) Ubuntu Chromium/25.0.1364.160 Chrome/25.0.1364.160 Safari/537.22

Steps to reproduce:

1.enter the camera app and select the camera mode
2.click the flash light icon to turn off the flash light
3.put the phone in dark environment and take picture


Actual results:

you can see the camera app only do auto focus but not take picture


Expected results:

the camera app should tell user that auto focus failed, but it should continue take picture.
Android don't have this issue.
If auto focus failed, camera also can't take picture.
blocking-b2g: --- → koi?
James, this is not reproducible with Hamachi. So I will remove 'koi?'.
blocking-b2g: koi? → ---
(In reply to pcheng from comment #3)
> James, this is not reproducible with Hamachi. So I will remove 'koi?'.

OK, because hamachi has no auto focus.
James, do you want this in Fugu's repo?
Flags: needinfo?(james.zhang)
(In reply to Steven Yang [:styang] from comment #5)
> James, do you want this in Fugu's repo?

It's better in v1.3 branch. If v1.3 refernce phone's camera support auto focus, it also has this issue when auto focus fails. I think you should fix this issue.
Flags: needinfo?(james.zhang)
(In reply to Steven Yang [:styang] from comment #5)
> James, do you want this in Fugu's repo?

It's better in fugu branch too.

Updated

5 years ago
blocking-b2g: --- → fugu?
(In reply to James Zhang from comment #7)
> (In reply to Steven Yang [:styang] from comment #5)
> > James, do you want this in Fugu's repo?
> 
> It's better in fugu branch too.

It's better in v1.2f and v1.3.

Updated

5 years ago
blocking-b2g: fugu? → ---
I don't have a fugu to test on. Is this still an issue we care about or we can close it?
Flags: needinfo?(james.zhang)
On dolphin and 1.4 we take the picture even if focus fails. I'm closing this bug.

James, pleas reopen if you want us to reconsider.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(In reply to Diego Marcos [:dmarcos] from comment #10)
> On dolphin and 1.4 we take the picture even if focus fails. I'm closing this
> bug.
> 
> James, pleas reopen if you want us to reconsider.

OK, I saw that we can take picture if focus fails.
Flags: needinfo?(james.zhang)
You need to log in before you can comment on or make changes to this bug.