Closed Bug 936479 Opened 6 years ago Closed 6 years ago

YouTube embed fails with "requires Flash" error in FxOS on tamiltvshows.net

Categories

(Web Compatibility :: Mobile, defect)

Other
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: hsteen, Unassigned)

References

()

Details

(Whiteboard: [mobile-compat-form] [video] [country-in])

Attachments

(1 file)

Site: http://www.tamiltvshows.net/2013/11/varam-tharuvaai-iraivaa-08-11-2013-zee.html
YouTube embed fails with "requires Flash error in FxOS on tamilstvhows.net

:: Steps To Reproduce

Try to view embedded video in FxOS. Fails although .it works on Firefox on Android.

:: Expected Result

video

:: Actual Result

no video

:: Additional Information

Software Version: 1.1
Reporter's User Agent: Mozilla/5.0 (Android; Mobile; rv:28.0) Gecko/28.0 Firefox/28.0
Summary: YouTube embed fails with "requires Flash error in FxOS on tamilstvhows.net → YouTube embed fails with "requires Flash error in FxOS on tamiltvshows.net
Summary: YouTube embed fails with "requires Flash error in FxOS on tamiltvshows.net → YouTube embed fails with "requires Flash" error in FxOS on tamiltvshows.net
The videos seem to rely on YouTube. 
Could you confirm Abdul?

on iPod Touch I receive the desktop site and I'm unable to play/test the video because of geo-restrictions. If the videos relies only on flash it will be not possible to test them on Firefox OS.
Whiteboard: [mobile-compat-form] → [mobile-compat-form] [video] [country-in]
Attached image tamilmovies.png
Yes. Videos rely on youtube. Some videos gets redirected to m.youtube.com and some are played directly through desktop site. See attachment.
hallvord: 
Do you think it is an issue specific to this Web site as if we contact the Web site we can get a resolution, or it's independent of the site.
Flags: needinfo?(hsteen)
I've left this in UCONFIRMED pending analysis, but my best *guess* at this point is that they perhaps link to a specific (outdated) version of some YouTube JS API, and this version is broken. (YouTube embeds work pretty much everywhere else, so it must be something peculiar here on this site.) Looking at what YT-related JS this runs compared to a site that successfully embeds videos would be a good first step.
Flags: needinfo?(hsteen)
Seems sorted out now - they apparently use a Wordpress plugin called detube, and all videos I could find either linked over to be played at m.youtube or worked fine inside this site. Yay :)

haseeb: verify?
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Yes, it is working fine.
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.