develop an extension to block comments matching admin-defined keywords

RESOLVED DUPLICATE of bug 935570

Status

()

RESOLVED DUPLICATE of bug 935570
5 years ago
5 years ago

People

(Reporter: bwinton, Unassigned)

Tracking

Production
x86
Mac OS X

Details

(URL)

Someone really doesn't like Australis, and as a result I'm getting a lot of email containing phrases including but not limited to "UX-Team is a **** bitch to **** in the ass!" and "sluts, whores suck my dick monsterkids!".  There are several words in there that I feel don't really help contribute to a constructive discussion, and so I would like to ask that these type of comments get pre-emptively blocked, so that we don't have to waste people's time manually deleting the comments themselves, and even more people's time and motivation deleting the notification email.

Perhaps, in order to make the offending party feel better, we could hellban them instead of just discarding the comment and giving an error.

Bug 860814 has had some examples in the past, and I suspect will have more in the future.

Thanks,
Blake.

Updated

5 years ago
Assignee: create-and-change → nobody
Component: Creating/Changing Bugs → Extensions: Other
Product: Bugzilla → bugzilla.mozilla.org
QA Contact: default-qa
Version: unspecified → Production
Problem with this is the person is creating many accounts from temp addresses. There is nothing stopping this person from creating another account, looking at the previous bug and seeing that the comments are not visible, etc.

dkl
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 936509
(Reporter)

Comment 3

5 years ago
That's only a problem with the hellbanning aspect, and only if you assume they're typing in all the comments directly, and not automating them.  (If they're automated, then they can check for errors if you don't hellban, and re-try with modified wording…  If they're automated and you hellban, then they think they succceeded, and likely don't bother re-trying.)

But other than that, I agree, and will happily follow bug 936509!  :)

Thank you!
Duping this to a Bugzilla bug is not going to help the immediate problem. We should come up with a b.m.o solution to filter out comments with obvious abuse.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
FTR, lest anyone be unfamiliar: hellbanning (aka ghostbanning) is a moderation technique where a user's activity is still visible to themselves, but not to others. It's quite effective for attention-seeking trolls, because the effect is that they're simply being ignored by everyone. At which point they tend to get bored and go away.
hellbanning is much harder, but simple blocking based on a list of keywords stored in a table should be easy to implement.
Summary: Block impolite comments, possibly with "hellbanning". → develop an extension to block comments matching admin-defined keywords
this was implemented over in bug 935570
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 935570
You need to log in before you can comment on or make changes to this bug.