If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash on Scirra SpaceBlaster benchmark

RESOLVED WORKSFORME

Status

()

Core
Canvas: WebGL
--
critical
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: Mayank Bansal, Assigned: jgilbert)

Tracking

({crash, regression})

28 Branch
x86_64
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(firefox27 unaffected, firefox28 affected, firefox29 affected)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 829892 [details]
about support.txt

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20131110030205

Steps to reproduce:

1. Create fresh profile.
2. Go to http://www.scirra.com/labs/sbperfgl/


Actual results:

firefox crashes


Expected results:

no crash
excellent performance

https://crash-stats.mozilla.com/report/index/c070ea91-6ba2-46c4-835b-5a4462131110
https://crash-stats.mozilla.com/report/index/badf1bc8-6ee4-495d-b08c-46adf2131110
https://crash-stats.mozilla.com/report/index/b97d2dae-d46e-4747-b212-610bb2131110
(Reporter)

Updated

4 years ago
Keywords: crash

Updated

4 years ago
Severity: normal → critical
Crash Signature: [@ sse2_blt ]
Version: 23 Branch → 28 Branch

Comment 1

4 years ago
Regression Window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/f0d363d72753
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131030193803
Bad:
http://hg.mozilla.org/mozilla-central/rev/e6b861af3117
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131031130944
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f0d363d72753&tochange=e6b861af3117

Regression Window(b2g-i)
Good:
http://hg.mozilla.org/integration/b2g-inbound/rev/4ded57b1a15c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131031064700
Bad:
http://hg.mozilla.org/integration/b2g-inbound/rev/d548421e14c5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131031065459
Pushlog:
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=4ded57b1a15c&tochange=d548421e14c5
Status: UNCONFIRMED → NEW
tracking-firefox28: --- → ?
Ever confirmed: true
Keywords: regression

Comment 2

4 years ago
In local build
Last good: d23ba68d326e
First bad: 175163f053f7

regressed by:
175163f053f7	Jeff Gilbert — Bug 924241 - Don't force-present after post-resize clear. r=bjacob
Blocks: 924241
Assignee: nobody → jgilbert

Comment 3

4 years ago
Is this a test suite we care about, or one that represents a normal user scenario? Trying to understand whether we should track for release.
Flags: needinfo?(jgilbert)
(Assignee)

Comment 4

4 years ago
Yeah, we want to track this, though I'd be surprised if this was limited to just this page.
Flags: needinfo?(jgilbert)

Updated

4 years ago
status-firefox27: --- → unaffected
status-firefox28: --- → affected
tracking-firefox28: ? → +
sse2_blt is #220 on the crash reports list for Firefox 28 for the last 7 days, with only 8 crashes. 

Jeff, do you still want to track that for Firefox 28? I am in the process of learning about crash report triage.
Flags: needinfo?(jgilbert)
(Assignee)

Updated

4 years ago
Component: Canvas: 2D → Canvas: WebGL
Flags: needinfo?(jgilbert)
(Reporter)

Comment 6

4 years ago
doesnt crash anymore.
Current Rank:
 * Firefox 29: #102 @ 0.13%
 * Firefox 28: #85 @ 0.17%
 * Firefox 27: N/A (32 crashes)
 * Firefox 26: N/A (86 crashes)

Crashes definitely still exist but it's very low volume. Given comment 6 I'm inclined to resolve this WORKSFORME.

@mayankleoboy1, can you please verify this no longer reproduces for you with either of the Firefox branches?
Flags: needinfo?(mayankleoboy1)
(Reporter)

Comment 8

4 years ago
tried this with a new profile and a variety of options. For each test i cleared the complete history and restarted Nightly.


default (omtc= off. textures = old)  :  load bench in new unfocussed tab, and dont switch till game loads completely = no crash
load bench in current tab = crash  
FPS = 60. CPU use= ~10%


OMTC on + old textures  : load bench in new unfocussed tab = no crash
load in current tab = no crash
FPS= 12-30. CPU=9%


OMTC+new textures  : load bench in new tab = no crash
FPS=21-30 . CPU use= 10%  Lots of jerky animation


Also, there is something related to caching. With the default mode (OMTC = off. textures=old). If i first open the bench in a new unfocussed tab, let it load, close it, then open the bench in the current tab, there is no crash.

I dont remember in which condition i made comment 6 .
Flags: needinfo?(mayankleoboy1)
Since the crash is no longer reproducible and is low volume on crashstats I think we should just call this WORKSFORME. We can reopen the bug if the crash resurfaces.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
status-firefox27: unaffected → ---
status-firefox28: affected → ---
tracking-firefox28: + → ---
(Reporter)

Comment 10

4 years ago
reopened as per comment 8
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Sorry, I missed that.

> default (omtc= off. textures = old)  :  load bench in new unfocussed tab, and dont switch till game loads completely = no crash
> load bench in current tab = crash  
> FPS = 60. CPU use= ~10%

Can you please explain this in more detail?
(Reporter)

Comment 12

4 years ago
1.create a new profile .
 Since it is default,
layers.offmainthreadcomposition.enabled = false
layers.use-deprecated-textures= true. 

2. Open https://bugzilla.mozilla.org/show_bug.cgi?id=936928
3. Click on the benchmark URL.  Crash

4. Now restart the browser, and open the benchmark by "ctrl+click" . Let the bench load/initialise in the unfocussed tab.  You wont get a crash.


The FPS and the CPU usage is as reported by the benchmark itself.
(In reply to mayankleoboy1 from comment #12)
> 1. create a new profile .
>  Since it is default,
> layers.offmainthreadcomposition.enabled = false
> layers.use-deprecated-textures= true. 
> 2. Open https://bugzilla.mozilla.org/show_bug.cgi?id=936928
> 3. Click on the benchmark URL.  Crash 
> 4. Now restart the browser, and open the benchmark by "ctrl+click" . Let the
> bench load/initialise in the unfocussed tab.  You wont get a crash.

What if you ctrl+click the benchmark URL in step 3?

In other words:
1. Start Firefox with a new profile
2. Open this bug report
3. CTRL+Click the benchmark URL
(Reporter)

Comment 14

4 years ago
no crash
So step 4 is pretty much moot. The real bug here is that Scirra SpaceBlaster crashes when opened in the foreground with layers.offmainthreadcomposition.enabled = false and layers.use-deprecated-textures= true.

In other words:
1. Start Firefox with a new profile
2. Ensure layers.offmainthreadcomposition.enabled = false and layers.use-deprecated-textures= true in about:config
3. Open this bug and left click the link in the URL field
> http://www.scirra.com/labs/sbperfgl/ loads in the current tab and eventually crashes

Is this correct?

Comment 16

4 years ago
bp-9b1c1d63-8ff4-4279-8b08-d141e2140117

STR
1. Start Nightly29.0a1 with a new profile
2. Open this bug report and click http://www.scirra.com/labs/sbperfgl/

Actual Results:
Crash immediately

Updated

4 years ago
status-firefox27: --- → unaffected
status-firefox28: --- → affected
status-firefox29: --- → affected

Comment 17

4 years ago
(In reply to Alice0775 White from comment #16)
> 2. Open this bug report and click http://www.scirra.com/labs/sbperfgl/

When very low on memory I managed to get this: bp-eb210d96-ca25-4a42-b1c6-798572140401 by doing that. Probably not related.

This bp-bb12ec9b-a7f2-4451-92ea-c19be2140401 has this Bug on it's "Related Bugs" List. It was not caused by visiting http://www.scirra.com/labs/sbperfgl/ .

When this crash happened it triggered a WinXp BreakPoint Popup (from the OS) @ 0x002c:12cb in addition to popping up the MCR. The WinXP BPs have only started occurring this past week, prior to that I had not seen them in a few years.

I am running Nightly 31.0a1 (2014-04-01), I too disagree with Comment 9.

Bugs involving sse2_blt have only started (for me) in the past few days (and I do not visit Scirra or cimatron.partcommunity.com).
(Reporter)

Comment 18

2 years ago
cant reproduce anymore.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.