[v1.2] Remove transparent to blue transition of lock screen handle to workaround bug 919899 and performance issues

RESOLVED FIXED

Status

Firefox OS
Gaia::System::Lockscreen
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: timdream, Assigned: snowmantw)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(blocking-b2g:koi+, b2g-v1.2 fixed)

Details

(Whiteboard: [perf-reviewed][gfx_tpe])

Attachments

(1 attachment, 1 obsolete attachment)

Created attachment 830062 [details]
patch

The color transition is the major contributor to the repaint cycles when the user touches the unlock handle, and it makes the animation less smooth. In order to prevent that, we could scale back the design and remove the color transition.

The alternative would be to backout everything in v1.2 branch, and ship the v1.1 two step unlock handle. However the engineering effort is more than the one line patch proposed here.

Note that bug 919899 will be fixed altogether (while maintain the performance requirement) by switch to a canvas implementation in bug 919410.
Attachment #830062 - Flags: ui-review?(jachen)

Updated

5 years ago
Whiteboard: [perf-reviewed]
Comment on attachment 830062 [details]
patch

We would also need to remove the black line when the handle shrink back too.
Attachment #830062 - Attachment is obsolete: true
Attachment #830062 - Flags: ui-review?(jachen)
Assignee: timdream → gweng
(Assignee)

Comment 2

5 years ago
Created attachment 830616 [details] [review]
Patch -- glitches become invisible

Hide the glitches. Now they're gone both in bouncing back and extending stages.
Attachment #830616 - Flags: review?(timdream)
Attachment #830616 - Flags: ui-review?(jachen)
Attachment #830616 - Flags: review?(timdream)
Attachment #830616 - Flags: review+
(Assignee)

Comment 3

5 years ago
Cancel the animation after unlock to pin down the root cause of performance issue.
(Assignee)

Comment 4

5 years ago
Currently the fade-out lag seems irrelevant to the animation, or at least not the major issue.
(Assignee)

Comment 5

5 years ago
Well now I can capture there are 2 reflows after I unlock my device:

17:38:33.822 reflow: 7.14ms
17:38:34.735 reflow: 24.23ms

Unfortunately it reports no stack information. However, these 2 reflows may be the reason of FPS dropping.
(Assignee)

Comment 6

5 years ago
I've found that even after I turn the fade-out animation off, the reflows still occur. The UI become smoother when I did so. So, the reflows seems irrelevant to the problem.
Comment on attachment 830616 [details] [review]
Patch -- glitches become invisible

Given the fact we need to debug the unlock "fly-out" transition, I would like to land this patch now. If we ended up decide not to use the new unlock handle for v1.2, we could file another bug to remove it altogether.
Attachment #830616 - Flags: ui-review?(jachen)
Whiteboard: [perf-reviewed] → [perf-reviewed][gfx_tpe]
master: https://github.com/mozilla-b2g/gaia/commit/002578cc3cd0ca31e1333aafd8d019d9dd83e408

and we need this for v1.2
Status: NEW → RESOLVED
blocking-b2g: --- → koi+
Last Resolved: 5 years ago
Resolution: --- → FIXED
FYR the Gecko work involving fly-out transition is bug 937630.
(Assignee)

Comment 10

5 years ago
Device information:

On Unagi + 1.2 this would happen, while Inari + 1.1 won't.
On Unagi + 1.1 this won't happen, while Inari + 1.2 would.
On Nexsus 4 + 1.2 this would happen.
Uplifted 002578cc3cd0ca31e1333aafd8d019d9dd83e408 to:
v1.2: f86d0602fae2752376ed7bcad317a15382ec9d60
status-b2g-v1.2: --- → fixed
You need to log in before you can comment on or make changes to this bug.