Clipping/displayport issues when scrolling a subframe with a keyboard

RESOLVED DUPLICATE of bug 933264

Status

defect
RESOLVED DUPLICATE of bug 933264
6 years ago
5 years ago

People

(Reporter: mbrubeck, Unassigned)

Tracking

Trunk
x86_64
Windows 8.1

Firefox Tracking Flags

(firefox28 verified, firefox29 verified)

Details

Attachments

(2 attachments)

Reporter

Description

6 years ago
Posted file test case
Steps to reproduce:
1) Load a page with a scrollable subframe, like the attached test case.
2) Touch and drag to scroll the subframe.
3) Then, use the arrow keys or pgup/pgdown to scroll the subframe.

Results: The content of the subframe does not scroll, and instead appears to be clipped incorrectly (regions of the frame replaced with white).
Reporter

Comment 1

6 years ago
Posted image screenshot
Reporter

Comment 2

6 years ago
Maybe related to bug 933264.
Depends on: 933264
Reporter

Updated

6 years ago
Summary: Clipping/displayport issues in scrollable subframe when scrolling with keyboard → Clipping/displayport issues when scrolling a subframe with a keyboard
Tentatively marking as a rollout blocker, but I could be persuaded to not do so. This feels a bit corner case, but for user who navigate via the keyboard it's a deal killer on using the browser.
Whiteboard: [beta28]
Blocks: metrov1backlog, metrov1omtc&apzc
No longer blocks: metro-apzc
The clipping issue should be fixed by bug 933264. We probably still won't async scroll these types of elements until bug 939239 is fixed though.
Reporter

Comment 5

6 years ago
Confirmed this is fixed by bug 933264.
Status: NEW → RESOLVED
Closed: 6 years ago
No longer depends on: 933264
Resolution: --- → DUPLICATE
Duplicate of bug: 933264
No longer blocks: metrov1backlog, metrov1omtc&apzc
Whiteboard: [beta28]
Kamil, can you please verify this is fixed?
Flags: needinfo?(kamiljoz)
Went through the following verification process using the following builds:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-20-03-02-02-mozilla-central/
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-20-00-40-01-mozilla-aurora/
- http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/28.0b4/win32/en-US/

- Ensured that you can scroll through the subframe via touch gestures
- Ensured that you can scroll through the subframe via the mouse via the scroll bars
- Ensured that you can scroll through the subframe via the arrow keys (up, down, right, left)
- Ensured that you can scroll through the subframe via the Page Up & Pade Down keys
- Ensured that the scrolling looked smooth without any jank or flickering
- Ensured that all of the above test cases worked with different variations of snapped view
Flags: needinfo?(kamiljoz)
You need to log in before you can comment on or make changes to this bug.