[e10s] Selecting an item in a <select> does not trigger onChange

RESOLVED FIXED in Firefox 29

Status

()

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: TimAbraldes, Assigned: billm)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 29
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

STR:
With e10s enabled, go to any open bug in bugzilla.mozilla.org and try to set its status to RESOLVED.

Normally a second <select> would appear for you to select a resolution, but with e10s enabled, the second <select> never appears
Created attachment 8338130 [details] [diff] [review]
select-element-onchange

Changing selectIndex apparently doesn't fire the onchange handler.
Assignee: nobody → wmccloskey
Status: NEW → ASSIGNED
Attachment #8338130 - Flags: review?(felipc)
Attachment #8338130 - Flags: review?(felipc) → review+
Metro seems to use a different version of initEvent for this same functionality, but I can't find the definition for that function anywhere.. http://mxr.mozilla.org/mozilla-central/source/browser/metro/base/content/contenthandlers/FormHelper.js#699
Shouldn't we dispatch change event only if the value actually changes.
So perhaps if (this.element.selectedIndex != message.data.value) ...
https://hg.mozilla.org/mozilla-central/rev/0af44c4131fb
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Duplicate of this bug: 927123
You need to log in before you can comment on or make changes to this bug.