If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Flatfish][FTU] update images and wordings in Tutorial Steps

RESOLVED FIXED

Status

Firefox OS
Gaia::First Time Experience
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: eragonj, Assigned: eragonj)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug][mentor=ejchen][mentor-lang=zh][developer+])

Attachments

(3 attachments)

UX has new images and wordings for flatfish in FTU.
Whiteboard: good first bug
Whiteboard: good first bug → [good first bug][mentor=ejchen]
Created attachment 830728 [details]
FTU_20131111.zip

This zip contains latest UX flow and needed l10n strings, images.
Created attachment 832132 [details] [review]
patch
Comment on attachment 832132 [details] [review]
patch

Hola Borja,

I just updated the patch and please help me review it. 

This has been tested on mobile and tablet and been reviewed by VD and UX. 

Gracias :D
Attachment #832132 - Flags: review?(borja.bugzilla)
Whiteboard: [good first bug][mentor=ejchen] → [good first bug][mentor=ejchen][mentor-lang=zh]

Updated

4 years ago
blocking-b2g: --- → 1.3+
Whiteboard: [good first bug][mentor=ejchen][mentor-lang=zh] → [good first bug][mentor=ejchen][mentor-lang=zh][developer+]

Updated

4 years ago
blocking-b2g: 1.3+ → ---
Comment on attachment 832132 [details] [review]
patch

Small fix and I'll R+ and merge this!! :) Gracias!!!
Attachment #832132 - Flags: feedback+
(In reply to Borja Salguero [:borjasalguero] from comment #4)
> Comment on attachment 832132 [details] [review]
> patch
> 
> Small fix and I'll R+ and merge this!! :) Gracias!!!

thanks Borja, i will test the small details you mentioned on flatfish later !
(In reply to Borja Salguero [:borjasalguero] from comment #4)
> Comment on attachment 832132 [details] [review]
> patch
> 
> Small fix and I'll R+ and merge this!! :) Gracias!!!

Borja, I need your review again. Thanks :)
Hi Ej! I will try to test with the emulator, but not having a Flatfish for testing is not really good... :( Joe, do you know if it would be possible to ask for one Flatfish device for accelerating all the Flatfish reviews related with FTU, Contacts...? It would be great if we could have one of these devices in London' offices at least for a couple of months. Wdyt?
Flags: needinfo?(jcheng)
(In reply to Borja Salguero [:borjasalguero] from comment #7)
> Hi Ej! I will try to test with the emulator, but not having a Flatfish for
> testing is not really good... :( Joe, do you know if it would be possible to
> ask for one Flatfish device for accelerating all the Flatfish reviews
> related with FTU, Contacts...? It would be great if we could have one of
> these devices in London' offices at least for a couple of months. Wdyt?

Hola, Borja.

Based on some headquarters' decisions (I think it is on internal mailing list, but I forgot which one), it seems that development on flatfish is not with high priority now. 

As you can see, the flatfish todo list on Taipei Gaia team has been put into pending mode : https://wiki.mozilla.org/Gaia/Team/Taipei#Tablet_.28v1.3.29

And also, there is no flag on this bug, in this way, I think we can postpone this patch and wait for further notification, wdyt :)?

BTW, I thought you already brought one flatfish back to Español after workweek xD.
(In reply to Borja Salguero [:borjasalguero] from comment #7)
> Hi Ej! I will try to test with the emulator, but not having a Flatfish for
> testing is not really good... :( Joe, do you know if it would be possible to
> ask for one Flatfish device for accelerating all the Flatfish reviews
> related with FTU, Contacts...? It would be great if we could have one of
> these devices in London' offices at least for a couple of months. Wdyt?

yes i am working on it. i will let you/Noemi know soon
Flags: needinfo?(jcheng)
Borja, I am back again !

After discussion with PM, it seems that this patch is needed and have to be reviewed soon ! Can you take few time help me review this patch ? We need to fix the wordings and image. 

Thanks Borja !
Flags: needinfo?(borja.bugzilla)
It also works well on master (when rebased on local). If this change is ok, I will squash commits and push again. Thanks Borja !!
Ej! Im waiting for the flatfish (we are waiting to receive it in London!), so as soon as I have it I'll review all this stuff and everything related with Flatfish! \m/!
Flags: needinfo?(borja.bugzilla)
Oh ok ! I thought it was there already. Thanks Borja.
Comment on attachment 832132 [details] [review]
patch

Borja and EJ,

I am informed by Francis (the PM on the flatfish project) that he would need the patch landed on master before Monday Taipei time. I am asking Vivien, who is in Paris, to see if he could verify the patch with a device.

It seems to me the patch only apply to tablets with responsive design, so the risk to break the phone build is minimum. I will manually verify that too if I don't hear Vivien's response by Monday.

We could always back the code out later (or do follow-up fixes) if there is problems.
Attachment #832132 - Flags: review?(21)
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #14)
> Comment on attachment 832132 [details] [review]
> patch
> 
> Borja and EJ,
> 
> I am informed by Francis (the PM on the flatfish project) that he would need
> the patch landed on master before Monday Taipei time. I am asking Vivien,
> who is in Paris, to see if he could verify the patch with a device.
> 
> It seems to me the patch only apply to tablets with responsive design, so
> the risk to break the phone build is minimum. I will manually verify that
> too if I don't hear Vivien's response by Monday.
> 
> We could always back the code out later (or do follow-up fixes) if there is
> problems.

Thanks Tim. I will try to rebase this patch on master first because there are some image files conflicted caused by Bug 959659 few days ago.
Just updated the patch on Github and it is green on Travis now !
(In reply to EJ Chen [:eragonj] from comment #16)
> Just updated the patch on Github and it is green on Travis now !

EJ, could you upload all screenshots of the screens of both phone/tablet you modified? That will be helpful to the review process.
Flags: needinfo?(ejchen)
Created attachment 8362393 [details]
screenshots for FTU in mobile & tablet

@Tim, just attached all screenshots (mobile & tablet). Thanks
Flags: needinfo?(ejchen)
Borja,

Would that be enough for you to review it today? If not I will manually verify the patch locally and check-in the patch first.
Flags: needinfo?(borja.bugzilla)
Im going to review this right now, due to the Flatfish is now in my hands! I'll come with feedback in a few minutes, but for sure that this will be ready to land due to Ej did a great job. Stay tuned
Flags: needinfo?(borja.bugzilla)
Comment on attachment 832132 [details] [review]
patch

Reviewing I've found small but important issue. Check github.
Attachment #832132 - Flags: review?(21)
Ej, the fix here https://github.com/mozilla-b2g/gaia/pull/13695#issuecomment-32882979 :)
(In reply to Borja Salguero [:borjasalguero] from comment #22)
> Ej, the fix here
> https://github.com/mozilla-b2g/gaia/pull/13695#issuecomment-32882979 :)

ok just updated ! This one must be left from last bug when developing new FTU flow. Please try again, thanks Borja :)
Attachment #832132 - Flags: review?(borja.bugzilla) → review+
https://github.com/mozilla-b2g/gaia/commit/cc3f14a78005d52ae9f38242e185d77bae78b747
https://github.com/EragonJ/gaia/commit/20f6684b7626bb432b3c4caaa608c03d4938df4d
R+. Merged.

Thanks Ej for your great job and patience. As we have just received the FlatFish device, all reviews are going to be faster than before for sure! Thanks a lot! Gracias :)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(In reply to Borja Salguero [:borjasalguero] from comment #24)
> https://github.com/mozilla-b2g/gaia/commit/
> cc3f14a78005d52ae9f38242e185d77bae78b747
> https://github.com/EragonJ/gaia/commit/
> 20f6684b7626bb432b3c4caaa608c03d4938df4d
> R+. Merged.
> 
> Thanks Ej for your great job and patience. As we have just received the
> FlatFish device, all reviews are going to be faster than before for sure!
> Thanks a lot! Gracias :)

Muy bien ! Thanks for your help on reviewing the patch, Borja. Yeah ! :D
You need to log in before you can comment on or make changes to this bug.