ASSERTION: OmxDecoder should be in play state to continue decoding: 'result == NS_OK'

RESOLVED DUPLICATE of bug 919590

Status

Firefox OS
AudioChannel
RESOLVED DUPLICATE of bug 919590
4 years ago
4 years ago

People

(Reporter: shawnjohnjr, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
11-12 08:41:31.122 I/Gecko:ProcessPriorityManager(  178): [Music, child-id=4, pid=946] Got wake lock changed event. Now mHoldsCPUWakeLock=0, mHoldsHighPriorityWakeLock=0
11-12 08:41:31.302 V/EventHub(  178): /dev/input/event6 got: time=267.408612, type=1, code=200, value=1
11-12 08:41:31.302 V/EventHub(  178): /dev/input/event6 got: time=267.408642, type=0, code=0, value=0
11-12 08:41:31.342 I/Gecko:ProcessPriorityManager(  178): [Music, child-id=4, pid=946] Got wake lock changed event. Now mHoldsCPUWakeLock=1, mHoldsHighPriorityWakeLock=0
11-12 08:41:31.352 I/Gecko   (  946): [Child 946] WARNING: NS_ENSURE_TRUE(nsContentUtils::IsCallerChrome()) failed: file ../../../../../../../workspace1/b2g-inbound/b2g-inbound-src/content/html/content/src/HTMLAudioElement.cpp, line 235
11-12 08:41:31.362 V/EventHub(  178): /dev/input/event6 got: time=267.439407, type=1, code=200, value=0
11-12 08:41:31.362 V/EventHub(  178): /dev/input/event6 got: time=267.439437, type=0, code=0, value=0
11-12 08:41:31.382 E/GKI_LINUX(  178): ##### ERROR : timer_thread: tick delayed > 5 slots (-62054007,-50000000) -- cpu overload ? #####
11-12 08:41:31.392 E/GKI_LINUX(  178): ##### ERROR : timer_thread: tick delayed > 5 slots (-64964125,-50000000) -- cpu overload ? #####
11-12 08:41:31.392 E/GKI_LINUX(  178): ##### ERROR : timer_thread: tick delayed > 5 slots (-56123899,-50000000) -- cpu overload ? #####
11-12 08:41:31.402 E/GKI_LINUX(  178): ##### ERROR : timer_thread: tick delayed > 5 slots (-54181278,-50000000) -- cpu overload ? #####
11-12 08:41:31.402 E/OMXCodec(  946): [OMX.google.mp3.decoder] called start in the unexpected state: 4
11-12 08:41:31.402 I/Gecko   (  946): [Child 946] ###!!! ASSERTION: OmxDecoder should be in play state to continue decoding: 'result == NS_OK', file ../../../../../../workspace1/b2g-inbound/b2g-inbound-src/content/media/omx/MediaOmxReader.cpp, line 423
11-12 08:41:31.422 I/audio_a2dp_hw(  172): out_set_parameters: state 1
11-12 08:41:31.422 I/str_params(  172): key: 'routing' value: '128'
11-12 08:41:34.426 E/OMXCodec(  946): [OMX.google.mp3.decoder] Timed out waiting for output buffers: 4/0
11-12 08:41:36.548 V/EventHub(  178): /dev/input/event6 got: time=272.655796, type=1, code=200, value=1
11-12 08:41:36.548 V/EventHub(  178): /dev/input/event6 got: time=272.655827, type=0, code=0, value=0
11-12 08:41:36.578 V/EventHub(  178): /dev/input/event6 got: time=272.685981, type=1, code=200, value=0
11-12 08:41:36.578 V/EventHub(  178): /dev/input/event6 got: time=272.686011, type=0, code=0, value=0
11-12 08:41:37.429 E/OMXCodec(  946): [OMX.google.mp3.decoder] Timed out waiting for output buffers: 4/0
11-12 08:41:37.789 V/EventHub(  178): /dev/input/event6 got: time=273.899043, type=1, code=200, value=1
11-12 08:41:37.789 V/EventHub(  178): /dev/input/event6 got: time=273.899074, type=0, code=0, value=0
11-12 08:41:37.839 I/Gecko   (  946): [Child 946] WARNING: NS_ENSURE_TRUE(nsContentUtils::IsCallerChrome()) failed: file ../../../../../../../workspace1/b2g-inbound/b2g-inbound-src/content/html/content/src/HTMLAudioElement.cpp, line 235
11-12 08:41:37.859 V/EventHub(  178): /dev/input/event6 got: time=273.929320, type=1, code=200, value=0
11-12 08:41:37.859 V/EventHub(  178): /dev/input/event6 got: time=273.929350, type=0, code=0, value=0
11-12 08:41:39.661 I/audio_a2dp_hw(  172): suspend_audio_datapath: state 1
11-12 08:41:39.661 E/bt-btif (  178): bta_av_str_stopped:audio_open_cnt=1, p_data afd77398
11-12 08:41:39.661 W/bt-btif (  178): bta_dm_rm_cback:1, status:6
11-12 08:41:39.691 W/bt-btif (  178): bta_dm_rm_cback:1, status:6
11-12 08:41:39.791 W/bt-btif (  178): ### UNDERRUN :: ONLY READ 0 BYTES OUT OF 512 ###
11-12 08:41:39.791 I/audio_a2dp_hw(  172): skt_disconnect: fd 26
11-12 08:41:39.791 E/bt-btif (  178): UIPC_Read : channel 1 closed
11-12 08:41:39.791 W/bt-btif (  178): ### UNDERRUN :: ONLY READ 0 BYTES OUT OF 512 ###
11-12 08:41:40.432 E/OMXCodec(  946): [OMX.google.mp3.decoder] Timed out waiting for output buffers: 4/0
11-12 08:41:43.425 E/OMXCodec(  946): [OMX.google.mp3.decoder] Timed out waiting for output buffers: 4/0
11-12 08:41:44.686 W/bt-btif (  178): dm_pm_timer expires
11-12 08:41:44.686 W/bt-btif (  178): dm_pm_timer expires 0
11-12 08:41:44.686 W/bt-btif (  178): proc dm_pm_timer expires
11-12 08:41:44.717 E/bt-btif (  178): bta_dm_pm_btm_status  hci_status=36
11-12 08:41:46.428 E/OMXCodec(  946): [OMX.google.mp3.decoder] Timed out waiting for output buffers: 4/0
11-12 08:41:49.432 E/OMXCodec(  946): [OMX.google.mp3.decoder] Timed out waiting for output buffers: 4/0
(Reporter)

Comment 1

4 years ago
I hit this bug on Nexus-4 when connecting with bluetooth a2dp.
STR:
1. Play/Pause music continuously
2. Music song status bar stopped to move
3. Assertion happened

Note: Kill Music app and restart again will recover this bug.
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
(Reporter)

Comment 2

4 years ago
Created attachment 830814 [details]
logcat.txt

Updated

4 years ago
See Also: → bug 919590
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 919590
You need to log in before you can comment on or make changes to this bug.