Closed Bug 937616 Opened 7 years ago Closed 7 years ago

Click-to-play notifications should track plugins that are no longer present in the page

Categories

(SeaMonkey :: UI Design, defect)

defect
Not set
normal

Tracking

(seamonkey2.25 fixed, seamonkey2.26 fixed)

RESOLVED FIXED
seamonkey2.26
Tracking Status
seamonkey2.25 --- fixed
seamonkey2.26 --- fixed

People

(Reporter: neil, Assigned: neil)

Details

Attachments

(1 file, 1 obsolete file)

Some sites, such as apparently Google Earth, try to create a plugin but when they fail they remove it from the document again. This prevents someone from whitelisting the plugin.
Attached patch WIP (obsolete) — Splinter Review
Assignee: nobody → neil
Status: NEW → ASSIGNED
* Keeps track of plugin types used on a page
* Allow/Block applies to all types ever used on that page
* When remembering to allow, reload the page if some plugins no longer exist (always allow is the only way of accessing those plugins).

Note that when you use the last centre action the doorhanger is always removed even though there may be removed plugins to allow.
Attachment #830824 - Attachment is obsolete: true
Attachment #830833 - Flags: review?(bugzilla)
Attachment #830833 - Flags: feedback?(philip.chee)
For reference: The corresponding Firefox bug is Bug 745187 (they solved the bug another way)
Comment on attachment 830833 [details] [diff] [review]
Just handle the Always Activate case

I see, we don't remember the plugin-has-been-activated decision on reload. Patch looks fine, works fine and all tests pass.
Attachment #830833 - Flags: review?(bugzilla) → review+
Comment on attachment 830833 [details] [diff] [review]
Just handle the Always Activate case

f=me.
Attachment #830833 - Flags: feedback?(philip.chee) → feedback+
Pushed comm-central changeset 00705b36d10c.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.26
Comment on attachment 830833 [details] [diff] [review]
Just handle the Always Activate case

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: Lack of parity with Firefox 26
Testing completed (on m-c, etc.): Landed on c-c
Risk to taking this patch (and alternatives if risky):
String changes made by this patch: None
Attachment #830833 - Flags: approval-comm-aurora?
Attachment #830833 - Flags: approval-comm-aurora? → approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.