stsci.edu - Astroweb search gives no result, input name="isindex"

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
P3
major
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: Pierre Chanial, Assigned: Frankie)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
Build: 2001080104
Reproducibility: always

Steps:
- go to the above URL
- type 'planck'
- click go

Actual: The beginning of the result page is loaded but no result is displayed
Expected: 69 items should be displayed (NS4.x)

This bug can be reproduced as well typing
http://simbad.u-strasbg.fr/cgi-bin/search-master?isindex=planck
in the location bar.

(PS: this the major search engine for the astrophysics community)
(Reporter)

Comment 1

17 years ago
Bug still occurs with:
Linux     : build 2001081715
MacOS 9.2 : NS6.1
Win98     : NS6.1

I have put the search version from the Space Telescope Science Institute in the
URL field.
but all the version are broken:
http://cdsweb.u-strasbg.fr/astroweb.html

I think I have identified the problem:
The HTML form is written as <INPUT NAME="isindex" size=15>
and
NS 4.x redirects at http://simbad.u-strasbg.fr/cgi-bin/search-master?planck
NS 6.1 at http://simbad.u-strasbg.fr/cgi-bin/search-master?isindex=planck
the back end of the search only interpret successfully the first one.

Could you tell me please if the web site is correct or not?
I volunteer to send them an E-mail from the Evangelizator program :-)
Summary: Search result page incompletely loaded after submitting a form → stsci.edu/astroweb: search gives no result

Comment 2

17 years ago
Moving to evangelism
Assignee: rods → momoi
Severity: major → normal
Status: UNCONFIRMED → NEW
Component: Form Submission → Non-US English
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: vladimire → jonrubin
Version: other → unspecified

Comment 3

17 years ago
mass change, switching qa contact from jonrubin to ruixu.
QA Contact: jonrubin → ruixu
(Reporter)

Comment 4

16 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 5

16 years ago
A small issue still exists.

Go to http://www.stsci.edu/astroweb/search-master.html, and input 'planck', 
then press [Enter] key, (don't click 'Search AstroWeb' link):

1. NS6.2: point to http://www.stsci.edu/cgi-bin/search-master?isindex=planck
2. NS4.7 and IE5: point to http://www.stsci.edu/cgi-bin/search-master?planck and got search results.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 6

15 years ago
The form was probably created with the old ISINDEX tag, and was retrofitted with
an input tag.

STSCI is 5 minutes from my office. Someone remind me to look up Bob Jackson in
the campus directory and give him a call.
Assignee: momoi → francis_uy
Severity: normal → major
Status: REOPENED → NEW
Component: English: Non-US → US Edu
OS: Linux → All
Priority: -- → P3
Hardware: PC → All
Summary: stsci.edu/astroweb: search gives no result → stsci.edu/astroweb - search gives no result, input name="isindex"
(Assignee)

Comment 7

15 years ago
Bob Jackson no longer works at STSCI, so I contacted Glenn Miller, a current IT
staffer there. 

Glenn has never touched Astroweb. It apparently has been running in the
background for the past few years. He has added it to his task list, although
it's low priority. He will probably delete the script and redirect to
U-Strasbg.fr, which now works correctly with Mozilla.
Status: NEW → ASSIGNED
Summary: stsci.edu/astroweb - search gives no result, input name="isindex" → stsci.edu - Astroweb search gives no result, input name="isindex"
Target Milestone: --- → Jun

Comment 8

15 years ago
tech evang june 2003 reorg
Component: US Edu → English US
Target Milestone: Jun → ---

Comment 9

14 years ago
Page is still present, and also still does not work correctly.

Searching from the URI logged with the bug report redirects me (FB0.7 and IE6)
to http://www.stsci.edu/cgi-bin/search-master

Searching from there, however, displays results. I'm guessing due to the age of
this report that this is a pretty obselete issue. I'll contact them tomorrow to
see if one of the IT staff will remove and redirect as previously stated.

Comment 10

14 years ago
Just recieved the following email:

"If you need to respond to this message please do so by replying to this message
or create a new message with call number CNSHD385390 included in the subject line.

Current Call log entry :  
  
   Ben,
    I've looked into the problem you reported with astroweb at the STScI
   and found that the file which causes the problem is one which we 
   copy from another astroweb site - the National Radio Astronomy
   Observatory in Charlottesville, Virginia. So it turns out that the STScI
   cannot  fix the problem. I have sent 2 emails to the curator of that
   site, but I've not received a reply yet. Therefore I will be closing this
   problem report. If NRAO gets back to us, I will guide them in fixing
   the problem. You could transfer your Mozilla bug report to NRAO
   for resolution.
   
   Glenn Miller"

http://www.nrao.edu/ is the site for NRAO.
Depends on: 326369
Note that this bug is not about the <isindex> element, but rather about <input> elements with name=isindex.
(name=isindex is how IE does <isindex>)
404
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago9 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.