Closed Bug 938030 Opened 6 years ago Closed 6 years ago

Intermittent TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/general/browser_save_private_link_perwindowpb.js | uncaught exception - TypeError: aTarget is null at chrome://mochikit/content/tests/SimpleTest/EventUtils.j

Categories

(Core :: DOM: Core & HTML, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla28
Tracking Status
firefox26 --- fixed
firefox27 --- fixed
firefox28 --- fixed
firefox-esr24 --- fixed
b2g-v1.2 --- fixed

People

(Reporter: cbook, Assigned: smaug)

References

(Blocks 1 open bug, )

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Rev3 Fedora 12 mozilla-inbound debug test mochitest-browser-chrome on 2013-11-12 21:35:14 PST for push 4631a830ba92

slave: talos-r3-fed-090

https://tbpl.mozilla.org/php/getParsedLog.php?id=30518493&tree=Mozilla-Inbound

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/general/browser_save_private_link_perwindowpb.js | uncaught exception - TypeError: aTarget is null at chrome://mochikit/content/tests/SimpleTest/EventUtils.js:287
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/general/browser_save_private_link_perwindowpb.js | Test timed out
TEST-UNEXPE
So, img at [1] is null.

[1] http://hg.mozilla.org/mozilla-central/annotate/5f0569c3cb8f/browser/base/content/test/general/browser_save_private_link_perwindowpb.js#l100

I cannot find the original author of this test, but I'm definitely not the the one that should look into this.  I don't think this is caused by the cache2 changes (bug 913807) as it would show up earlier.

jdm, ehsan, do you know this test or do you know who knows?
Waiting for pageshow and then using executeSoon is obviously brittle. We should probably wait for something like DOMContentLoaded instead.
(In reply to comment #2)
> Waiting for pageshow and then using executeSoon is obviously brittle. We should
> probably wait for something like DOMContentLoaded instead.

I gave that a shot but neither DOMContentLoaded or load seem to fire.
Attached patch pb_test.diffSplinter Review
I get this on linux (and linux only!) occasionally when perf-mode is removed from appshell. We're racing with PAC file loading.
Assignee: nobody → bugs
Attachment #832484 - Flags: review?(ehsan)
Blocks: 930793
Attachment #832484 - Flags: review?(ehsan) → review+
https://hg.mozilla.org/mozilla-central/rev/489eb19fbb5e
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
You need to log in before you can comment on or make changes to this bug.