FTP directory shows wrong date for "near future" files

VERIFIED DUPLICATE of bug 61235

Status

()

Core
Networking: FTP
VERIFIED DUPLICATE of bug 61235
17 years ago
16 years ago

People

(Reporter: Peter Anvin, Assigned: dougt)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
FTP file directories unfortunately have no standard form, although they are
frequently given in Unix "ls -l" format.  The ls -l format uses a different
form, which lacks year, for files younger than 6 months of age or from the
slight future.  Unfortunately, there is no standard *TIME ZONE* for these files,
and no standard way to query such a time zone.  Some large FTP sites have
"solved" this by going to displaying time in UTC, but smaller FTP sites
generally show local time at the FTP site.

All of this means that it's very easy for an FTP site to return a value which is
in the "near future" as far as Mozilla is concerned.  Unfortunately, Mozilla (as
well as earlier versions of Netscape, it seems) interprets these "near future"
dates as being 1 year in the past -- resulting in lots of spurious bug reports
from users who think Netscape/Mozilla is actually displaying reality, whereas it
in fact has caused data corruption on its own accord.

Mozilla should either not canonicalize the output and just show what the FTP
server displays -- since it is for human use there is something to be said for
that solution -- or it needs to correctly take into account that between
incorrectly set clocks and time zone problems, "near future" dates are going to
happen, and it should add some margin.

Since "ls -l" will generally display the year-less form only for 6 months into
the past, it is probably safe to give at least 1 month worth of "near future"
slack time.
-> Networking FTP
Assignee: asa → dougt
Component: Browser-General → Networking: FTP
QA Contact: doronr → benc

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 61235 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
+verifyme - anyone agree w/ marking this a dupe?
Keywords: verifyme

Comment 4

16 years ago
VERIFIED:
reporter, please read bug 61235 and reopen if we are missing someting.
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.