B2G STK: Correct BIP command const.

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: gwang, Assigned: gwang)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 4 obsolete attachments)

(Assignee)

Description

5 years ago
From TS 102.223.
OPEN_CHANNEL, CLOSE_CHANNEL, SEND_DATA, RECEIVE_DATA should be 0x40~0x43
(Assignee)

Comment 1

5 years ago
Created attachment 832043 [details] [diff] [review]
Part1: Correct STK BIP command ID.
Assignee: nobody → gwang
Status: NEW → ASSIGNED
(Assignee)

Comment 2

5 years ago
Created attachment 832044 [details] [diff] [review]
Part2: Correct STK BIP command ID in RIL.
(Assignee)

Comment 3

5 years ago
Created attachment 832048 [details] [diff] [review]
Part3: Modify xpcshell test for bip message id change.
(Assignee)

Updated

5 years ago
Blocks: 791161
(Assignee)

Updated

5 years ago
Attachment #832043 - Flags: review?(allstars.chh)
(Assignee)

Updated

5 years ago
Attachment #832044 - Flags: review?(allstars.chh)
(Assignee)

Updated

5 years ago
Attachment #832048 - Flags: review?(allstars.chh)
(Assignee)

Comment 5

5 years ago
Created attachment 832122 [details] [diff] [review]
Part1: Correct STK BIP command ID.

Update UUID due to IDL change.
Attachment #832043 - Attachment is obsolete: true
Attachment #832043 - Flags: review?(allstars.chh)
Attachment #832122 - Flags: review?(allstars.chh)
(Assignee)

Updated

5 years ago
Blocks: 908554
Attachment #832122 - Flags: review?(htsai)
Attachment #832122 - Flags: review?(allstars.chh)
Attachment #832122 - Flags: review+
Attachment #832044 - Flags: review?(allstars.chh) → review+
Attachment #832048 - Flags: review?(allstars.chh) → review+
Duplicate of this bug: 937457
Please also provide the marionette test here.
(Assignee)

Comment 8

5 years ago
Created attachment 8333620 [details] [diff] [review]
Part4: STK Marionette test for BIP commands
(Assignee)

Comment 9

5 years ago
TRY:https://tbpl.mozilla.org/?tree=Try&rev=92d636874add
Part4 patch is parent of 241ed058b5ba.
(Assignee)

Updated

5 years ago
Attachment #8333620 - Flags: review?(allstars.chh)
Comment on attachment 8333620 [details] [diff] [review]
Part4: STK Marionette test for BIP commands

Review of attachment 8333620 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/icc/tests/marionette/test_stk_bip_command.js
@@ +15,5 @@
> +let tests = [
> +  {command: "d04b81030140018202818205074f70656e204944350702030403041f0239020578470a065465737447700272730d08f4557365724c6f670d08f4557365725077643c0301ad9c3e052101010101",
> +   func: testBipCommand,
> +   expect: {name: "open_channel_1",
> +            id: icc.STK_CMD_OPEN_CHANNEL,

s/id/typeOfCommand/
Attachment #8333620 - Flags: review?(allstars.chh) → review+
(Assignee)

Comment 11

5 years ago
Created attachment 8335874 [details] [diff] [review]
Part4: STK Marionette test for BIP commands v2.

id => typeOfCommand
Attachment #8333620 - Attachment is obsolete: true
Comment on attachment 832122 [details] [diff] [review]
Part1: Correct STK BIP command ID.

Review of attachment 832122 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry for the delay. r=me, thanks.
Attachment #832122 - Flags: review?(htsai) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
Keywords: checkin-needed
(Assignee)

Comment 13

5 years ago
TRY: https://tbpl.mozilla.org/?tree=Try&rev=8d64009a58a6
**Bug938466's patches are parents of Bug908554**
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
(Assignee)

Comment 16

5 years ago
Created attachment 8339157 [details] [diff] [review]
Part4: STK Marionette test for BIP commands v3.

Modify marionette constant base on Bug 814637.
Attachment #8335874 - Attachment is obsolete: true
(Assignee)

Comment 17

5 years ago
Created attachment 8339159 [details] [diff] [review]
Part1: Correct STK BIP command ID. v2.

Update UUID.
Attachment #832122 - Attachment is obsolete: true
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
Keywords: checkin-needed
You need to log in before you can comment on or make changes to this bug.