Address Boook not functional (bug 78933 regression?)

VERIFIED INVALID

Status

SeaMonkey
MailNews: Address Book & Contacts
--
blocker
VERIFIED INVALID
17 years ago
14 years ago

People

(Reporter: Jacek Piskozub, Assigned: chuang)

Tracking

({smoketest})

Trunk
smoketest

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
A CVS Win32 trunk build created after the 8/04 check-in for bug 78933 has empty
address book on existing profiles. To make it worse, it is impossible to add any
new address to the empty addressbook as the OK button seems dead.

Comment 1

17 years ago
I'm pulling & building on my home machine in an attempt to reproduce (everything
worked fine on Saturday checkin :-/).  That'll be a couple of hours, and then
I'll update here...
(Reporter)

Comment 2

17 years ago
Just to be sure, I deleted component.reg and made a new CVS build. This
miraculously healed the address book. It seems the bug was invalid, after all.
Marking.

Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 3

17 years ago
I get the following error with tonights CVS build on solaris:
error verifying accounts [Exception... "Could not convert Native argument arg 0
[nsIMsgAccountManager.accounts]"  nsresult: "0x8057000a
(NS_ERROR_XPC_BAD_CONVERT_NATIVE)"  location: "JS frame ::
chrome://messenger/content/accountUtils.js :: verifyAccounts :: line 74"  data:
no]
failed to set webshell window

After removing component.reg and running regxpcom it worked again.
I still got
failed to set webshell window
though.

I'm reopening this, and setting it as smoketest blocker. Just to be sure others
don't file dupes on this. (It dropped of today's bug list, too.)
The workaround should probably be on tinderbox.

Axel
Severity: major → blocker
Status: RESOLVED → REOPENED
Keywords: smoketest
OS: Windows ME → All
Hardware: PC → All
Resolution: INVALID → ---

Comment 4

17 years ago
Sent mail to the hook (and therefore .builds) with the "remove component.reg"
info; that should be sufficient, I hope.  Closing.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → INVALID
cls, is this what you were seeing on friday?

Comment 6

17 years ago
Yes, that was the error I was seeing.  After I clobbered my build, I couldn't
reproduce it.


Comment 7

17 years ago
Mark it verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.