<hr> position not affected by CSS "border-width"

RESOLVED DUPLICATE of bug 20582

Status

()

--
trivial
RESOLVED DUPLICATE of bug 20582
17 years ago
5 years ago

People

(Reporter: herman, Assigned: attinasi)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.3) Gecko/20010801
BuildID:    2001080110

The position of the left end of an <hr> ruler is not adjusted according to CSS
"border-width" -- it is rendered the same position as it would in a non-CSS page.

The right end is rendered correctly.

Reproducible: Always
Steps to Reproduce:
1.Load the 'URL that demonstrates the problem you are seeing':
2.http://css.nu/examples/body-border.html
3.

The described problem is not present in MSIE 5.5 or NN 4.76 - trey render correctly

http://css.nu/examples/body-border.html
Isn't this a duplicate?
Assignee: asa → karnaze
Component: Browser-General → Layout
QA Contact: doronr → petersen
Whiteboard: DUPEME
Maybe related to bug 82768?  I couldn't find an exact dupe.  (Lots of CSS breaks
on HR, period...)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

17 years ago
Reassigning to attinasi.
Assignee: karnaze → attinasi

Comment 4

17 years ago
"margin:0" on the HR fixes this.

*** This bug has been marked as a duplicate of 20582 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.