Closed Bug 93892 Opened 21 years ago Closed 21 years ago

When bad HTML (or other) code is encountered on web pages, inform the user.

Categories

(SeaMonkey :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 6211

People

(Reporter: Peter, Assigned: asa)

Details

When bad HTML code is encountered on web pages, inform the user.

It should bring up a dialoue window informing the user that:
1. the visited site contains bad code.
2. offers to save the error messages to a file (e.g., "line x is missing a close
tag").
3. suggests that the user send an email to the site informing them of the
problem (with error message file).

Of course, there should be a "remember this decision" button for people who
could care less about "saving the world" from poor HTML code.

Of course, this should include other code too (not just HTML).

If this practice catches on (also by other browsers), this will help avoid
forcing mozilla to compensate for poor web page design in the long term. More
importantly, it will highten the awareness of the fact that Mozilla is the
standards conform browser, and it is the other browsers (e.g., M$ IE) that do
not conform to standards ("this [bad] site was written for IE -> aha, it is IE
that is not adhering to standards").
Keywords: mozilla0.9.4
Whiteboard: Evangelism? This could kill IE, if it catches on.
There are other bugs on this.  We porbably have the capability to do this fro 
CSS, JS, DOM, and of course XML, but not HTML, since our HTML parser isn't 
compliant itself...

This bug is a duplicate, though, I think.
There's bug 6211 and bug 47108.
oh darm - I though I was being clever and original with this bug ;)

marking dup of bug 6211

*** This bug has been marked as a duplicate of 6211 ***
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
.
Status: RESOLVED → VERIFIED
Keywords: mozilla0.9.4
Whiteboard: Evangelism? This could kill IE, if it catches on.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.