Closed Bug 939012 Opened 6 years ago Closed 5 years ago

Inspector can get stuck after element is destroyed.

Categories

(DevTools :: Inspector, defect, P2)

25 Branch
x86_64
Linux
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: lb1.3, Unassigned)

References

Details

(Whiteboard: [polish-backlog])

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131028112446

Steps to reproduce:

After a jQuery dialog is destoryed, if you were inspecting something on it, the inspector panel breaks. For example:
http://jsfiddle.net/TCAgb/

After running this script, close the orange jQuery-dialog when the p tag in its contents is being inspected. With this element no longer existent, you can inspect the "log in" and other elements in the outer tab, but they will not highlight anything in the inspector panel - the inspector is now very broken.


Actual results:

Trying to move the inspector off a now-nonexistent element fails, and subsequent inspects also fail to highlight the element in the inspector DOM view. In the worst cases, the inspector panel can be completely blank where it should have the DOM nodes.


Expected results:

You should be able to always inspect elements in the inspector.
Confirmed with firefox-25.0.ru.linux64.
Works for me with 2013-11-14-03-02-04-mozilla-central-firefox-28.0a1.en-US.linux-x86_64.
Component: Untriaged → Developer Tools: Inspector
Thanks, can you mark this as "confirmed" please?
Checked on Nightly version 37.0a1 (2014-12-19) with Windows 7-64bit environment.Worked without get stuck.
Aleksej on irc just confirmed something like this happening on nightly:

If I understand correctly, this went away after: "I probably either or both: scrolled the page and shrunk the devtools."

Jeff, can you prioritize this against the devedition-40 list?
OK, maybe not the same bug - but we did see a stuck element in nightly, under different circumstances.
P2 for now - would really like to see a repro case and I don't understand the newer situation enough. If it was easy to repro, I would go P1.
Priority: -- → P2
Whiteboard: [devedition-40]
I'm unable to reproduce via the steps in the description.  We will definitely need STR or at least the page that it happened on before someone can work on it.
I have a feeling this was either Bug 1121528 or Bug 1036324.  Going to mark as worksforme since both of these were resolved since that bug report.  Please reopen if someone is able to reproduce.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
See Also: → 1121528, 1036324
Whiteboard: [devedition-40] → [polish-backlog]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.