Closed Bug 939135 Opened 7 years ago Closed 7 years ago

bug 840488 appears to have caused a 4% regression in dromaeo dom on linux 64

Categories

(Core :: DOM: Core & HTML, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jmaher, Assigned: bholley)

References

Details

(Keywords: perf, regression, Whiteboard: [talos_regression])

this seems to have caused a regression in dromaeo dom:
https://groups.google.com/forum/#!topic/mozilla.dev.tree-management/EFDaFc68RXY

we have had a lower volume of builds is why this hasn't been seen until now. 

oddly enough this seems to have improved the performance (reduced the noise) of win7 and win8:
http://graphs.mozilla.org/graph.html#tests=[[73,131,35],[73,131,37],[73,131,25],[73,131,33],[73,131,31]]&sel=1384221723000,1384394523000&displayrange=7&datatype=running
Yeah, this patch should improve perf in general. I'll profile this.
Assignee: nobody → bobbyholley+bmo
Flags: needinfo?(bobbyholley+bmo)
I haven't been able to reproduce this locally on OSX64.

I compiled two local revisions with --enable-profiling - one of trunk, one of trunk with my patches from bug 840488 backed out.

I then ran http://dromaeo.com/?dom-attr as a single tab in a clean profile.

With Patches Backed Out:
  runs: 2187, 2274, 2300, 2304, 2269
  mean: 2266
  sample result: http://dromaeo.com/?id=209921)
With Patches Not Backed Out:
  runs: 2207, 2295, 2295, 2266
  mean: 2265
  sample result: http://dromaeo.com/?id=209926)

Which indicates no change.

Here's what bz said over IRC a while back:

> The compare-talos looks like so: http://perf.snarkfest.net/compare-talos/breakdown.html?oldTestIds=31433033&newTestIds=31433999&testName=dromaeo_dom and http://perf.snarkfest.net/compare-talos/index.html?oldRevs=0d477f84d533&newRev=cd0e2e0ef136&submit=true

> Note that it shows a regression on all dromaeo DOM, just most on Ubuntu and on dom-attr.

> But the graph looks like http://graphs.mozilla.org/graph.html#tests=[[73,131,35]]&sel=1384221723000,1384394523000&displayrange=7&datatype=running which mostly looks like bimodal noise.

Boris, what do you think?
Flags: needinfo?(bobbyholley+bmo) → needinfo?(bzbarsky)
I suspect this is just noise... :(
Flags: needinfo?(bzbarsky)
OK then.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.