Closed Bug 939246 Opened 6 years ago Closed 6 years ago

Resample scrollbar width when OS X scrollbar behaviour changes

Categories

(Firefox :: Toolbars and Customization, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 928722

People

(Reporter: mconley, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [Australis:P3][Australis:M?])

In bug 898783, we compute the system width for a scrollbar when the menu panel is first opened in order to size the grid of icons correctly.

Unfortunately, OS X has a mode where the scrollbars have width of 0, and this mode is user-togglable at run-time - not just in the system settings, but simply by plugging in a USB Mouse.

We should re-sample the width if that setting changes. This might require us to file a platform bug to fire an event when the scrollbar behaviour changes.

See http://cl.ly/image/1P0R1v2B3i3e for what happens when the scrollbar width is not re-sampled.
Is this different from bug 928722? If so, how?
Good call!
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 928722
You need to log in before you can comment on or make changes to this bug.