Lock screen handle does not return to it's original position when you hit "cancel" from passcode panel

RESOLVED FIXED

Status

Firefox OS
Gaia::System::Lockscreen
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: timdream, Assigned: snowmantw)

Tracking

({regression})

unspecified
x86
Mac OS X
regression

Firefox Tracking Flags

(blocking-b2g:koi+, b2g-v1.2 fixed)

Details

(Whiteboard: [FT:System-Platform])

Attachments

(1 attachment)

STR:

1. set a passcode in the setting app
2. turn off the screen, and turn it back on
3. hit cancel
4. drag the handle to the unlock position to return to passcode screen
5. hit cancel

Expected:

1. a lock screen main panel with handle in it's original position

Actual:

1. handle remain in it's blue-ish engaged position.

Greg, could you fix this? Should be quick. Thanks.

Triage: should be blocked unless it does not reproduce in v1.2
Flags: needinfo?(gweng)
(Assignee)

Comment 1

5 years ago
I'll try it ASAP.
Flags: needinfo?(gweng)
(Assignee)

Comment 2

5 years ago
Created attachment 8333631 [details] [review]
Patch

Well, this may be a good first bug because of it's simplicity. However it's koi+, so here is the patch.
Attachment #8333631 - Flags: review?(timdream)
Comment on attachment 8333631 [details] [review]
Patch

Thanks!
Attachment #8333631 - Flags: review?(timdream) → review+
https://github.com/mozilla-b2g/gaia/commit/28e7dd59cf5b8ad9b197c59fbf92603e934e0474
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Hi Tim,

had to revert/backout this change in https://github.com/mozilla-b2g/gaia/commit/9f72bf98cb7c256d80c8cb2e5cbbeaa39fd15765 because of bustage/faiure in gaia unit tests like https://tbpl.mozilla.org/php/getParsedLog.php?id=30700831&tree=B2g-Inbound
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
So this was not reverted (see bug 937630 comment 50)
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Uplifted 28e7dd59cf5b8ad9b197c59fbf92603e934e0474 to:
v1.2: 927c819e44865171bf927aa40eb801d72ec81500
status-b2g-v1.2: --- → fixed
You need to log in before you can comment on or make changes to this bug.