Closed Bug 939602 Opened 6 years ago Closed 4 years ago

Shader editor artifact after mouse over shader

Categories

(Firefox :: Untriaged, defect)

27 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: pjcozzi, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.57 Safari/537.36

Steps to reproduce:

Visit http://cesium.agi.com/Cesium/Build/Apps/CesiumViewer/

Bring up the new Firefox WebGL shader editor.  There will be 11 shader programs.  Mouse over them until you find the one that highlights the center of the globe red.  Move the mouse away and the globe is now distorted.  See attached.
http://cesium.agi.com/Cesium/Build/Apps/CesiumViewer/ isn't available anymore. I get the 404 - File or directory not found error when accessing it.

Could you please post another link you can reproduce this problem with? Thanks!
Flags: needinfo?(pjcozzi)
Try

git clone https://github.com/AnalyticalGraphicsInc/cesium.git
cd cesium
./Tools/apache-ant-1.8.2/bin/ant build runServer

Browse to http://localhost:8080/Apps/CesiumViewer/index.html

More local build info: https://github.com/AnalyticalGraphicsInc/cesium/wiki/Contributor%27s-Guide#wiki-getstarted
Flags: needinfo?(pjcozzi)
I've tried the commands from comment 2, on Mac OS X 10.8.5.

After the " ./Tools/apache-ant-1.8.2/bin/ant build runServer " command in the console, I get the following error:

Error: JAVA_HOME is not defined correctly.
  We cannot execute /System/Library/Frameworks/JavaVM.framework/Home/bin/java

So I can't access http://localhost:8080/Apps/CesiumViewer/index.html

This bug is logged on Mac in 32-bit mode. Java doesn't work on Mac in 32-bit mode. Please see here for details: https://bugzilla.mozilla.org/show_bug.cgi?id=823533
I didn't managed to reproduce this issue on the latest release(43.0.4) nor the latest Nightly(46.0a1).

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20160105164030

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160111030207

Can you please try to reproduce this on the latest release(43.0.4) and latest Nightly(46.0a1) and provide the results?
When doing this, you could create a new clean Firefox profile, or maybe test in safe mode, as some of this issues may be caused by third party installed addons or custom settings
(https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems).

Thank you,
Vlad
Flags: needinfo?(pjcozzi)
Hi,

Considering the fact that the reporter did not provide more informations on my request, I will mark this issue as Resolved - WFM.
If you can still reproduce this, feel free to reopen it and provide the requested information.

Thanks
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Flags: needinfo?(pjcozzi)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.