Do not allow files which have custom build flags to be added to UNIFIED_SOURCES

UNCONFIRMED
Unassigned

Status

UNCONFIRMED
5 years ago
a year ago

People

(Reporter: Ehsan, Unassigned)

Tracking

Trunk
x86
macOS
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
AudioNodeEngineNEON.cpp is one such file.  The problem is that those flags are declared in the Makefile.in's, and if we're not lucky we might never realize that we're building those files with the wrong options.
I hit that with the SSE files under gfx/skia/ too. The idea proposed here would have saved me some time.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 939580
Gah, wrong bug
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Let's be realistic. This is not possible without moving this CXXFLAGS knowledge to moz.build, and I doubt we'll be there before most of the tree is built in unified mode.
Status: REOPENED → UNCONFIRMED
Ever confirmed: false
(Reporter)

Updated

5 years ago
Blocks: 940153
(Reporter)

Updated

5 years ago
Blocks: 939608
(Reporter)

Comment 5

5 years ago
Is there any workarounds that we could take in the mean time?
find -name Makefile.in | xargs grep OBJ_SUFFIX
(In reply to Mike Hommey [:glandium] from comment #4)
> Let's be realistic. This is not possible without moving this CXXFLAGS
> knowledge to moz.build

(and the dependency knowledge, like that issue in xpconnect)

Updated

a year ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.