Intermittent test_Range-comparePoint.html, test_Range-insertNode | application crashed [@ js::jit::IonBuilder::inlineScriptedCall(js::jit::CallInfo&, JSFunction*)] | Assertion failure: !analysisContext->isExceptionPending(), at IonBuilder.cpp:3809

RESOLVED DUPLICATE of bug 923614

Status

()

RESOLVED DUPLICATE of bug 923614
5 years ago
5 years ago

People

(Reporter: cbook, Unassigned)

Tracking

({assertion, crash, memory-leak})

Trunk
x86
Mac OS X
assertion, crash, memory-leak
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
Rev4 MacOSX Lion 10.7 mozilla-inbound debug test mochitest-2 on 2013-11-18 02:20:38 PST for push 4e64c6bb2732

slave: talos-r4-lion-037

https://tbpl.mozilla.org/php/getParsedLog.php?id=30689472&tree=Mozilla-Inbound

same as bug 923614 ?

Assertion failure: !analysisContext->isExceptionPending(), at ../../../js/src/jit/IonBuilder.cpp:3809
TEST-UNEXPECTED-FAIL | /tests/dom/imptests/html/dom/ranges/test_Range-comparePoint.html | application terminated with exit code 256
PROCESS-CRASH | /tests/dom/imptests/html/dom/ranges/test_Range-comparePoint.html | application crashed [@ js::jit::IonBuilder::inlineScriptedCall(js::jit::CallInfo&, JSFunction*)]
TEST-UNEXPECTED-FAIL | leakcheck | 2872 bytes leaked (CompositorChild, CondVar, Mutex, PCompositorChild, PLayerTransactionChild, ...)

02:40:36     INFO -  nsTraceRefcntImpl::DumpStatistics: 605 entries
02:40:36     INFO -  TEST-INFO | leakcheck | leaked 2 CompositorChild (1456 bytes)
02:40:36     INFO -  TEST-INFO | leakcheck | leaked 1 CondVar (32 bytes)
02:40:36     INFO -  TEST-INFO | leakcheck | leaked 1 Mutex (24 bytes)
02:40:36     INFO -  TEST-INFO | leakcheck | leaked 1 PCompositorChild (696 bytes)
02:40:36     INFO -  TEST-INFO | leakcheck | leaked 1 PLayerTransactionChild (72 bytes)
02:40:36     INFO -  TEST-INFO | leakcheck | leaked 1 RefCountedMonitor (64 bytes)
02:40:36     INFO -  TEST-INFO | leakcheck | leaked 1 RefCountedTask (16 bytes)
02:40:36     INFO -  TEST-INFO | leakcheck | leaked 1 ipc::MessageChannel (480 bytes)
02:40:36     INFO -  TEST-INFO | leakcheck | leaked 4 nsTArray_base (32 bytes)

02:40:36  WARNING -  PROCESS-CRASH | /tests/dom/imptests/html/dom/ranges/test_Range-comparePoint.html | application crashed [@ js::jit::IonBuilder::inlineScriptedCall(js::jit::CallInfo&, JSFunction*)]
02:40:36     INFO -  Crash dump filename: /var/folders/_3/ltjsbp0n7t79w4_648stl9x000000w/T/tmpKxLasj/minidumps/8BF6A489-0168-4320-AA00-F938ACD42FA9.dmp
02:40:36     INFO -  Operating system: Mac OS X
02:40:36     INFO -                    10.7.2 11C74
02:40:36     INFO -  CPU: amd64
02:40:36     INFO -       family 6 model 23 stepping 10
02:40:36     INFO -       2 CPUs
02:40:36     INFO -  Crash reason:  EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
02:40:36     INFO -  Crash address: 0x0
02:40:36     INFO -  Thread 0 (crashed)
02:40:36     INFO -   0  XUL!js::jit::IonBuilder::inlineScriptedCall(js::jit::CallInfo&, JSFunction*) [IonBuilder.cpp:4e64c6bb2732 : 3746 + 0x0]
02:40:36     INFO -      rbx = 0x00007fff78abd630   r12 = 0x0000000000000002
02:40:36     INFO -      r13 = 0x000000016ea0ce30   r14 = 0x00007fff5fbfa520
02:40:36     INFO -      r15 = 0x00007fff5fbfa9d8   rip = 0x0000000103a398ab
02:40:36     INFO -      rsp = 0x00007fff5fbf9c60   rbp = 0x00007fff5fbfa470
02:40:36     INFO -      Found by: given as instruction pointer in context
02:40:36     INFO -   1  XUL!js::jit::IonBuilder::inlineSingleCall(js::jit::CallInfo&, JSFunction*) [IonBuilder.cpp:4e64c6bb2732 : 4113 + 0x4]
02:40:36     INFO -      rbx = 0x000000016ea0c9c0   r12 = 0x000000014a040200
02:40:36     INFO -      r13 = 0x0000000000000001   r14 = 0x00007fff5fbfa9d8
02:40:36     INFO -      r15 = 0x00007fff5fbfa520   rip = 0x0000000103a3a433
02:40:36     INFO -      rsp = 0x00007fff5fbfa480   rbp = 0x00007fff5fbfa480
02:40:36     INFO -      Found by: call frame info
02:40:36     INFO -   2  XUL!js::jit::IonBuilder::inlineCallsite(js::Vector<JSObject*, 4ul, js::jit::IonAllocPolicy>&, js::Vector<JSObject*, 4ul, js::jit::IonAllocPolicy>&, bool, js::jit::CallInfo&) [IonBuilder.cpp:4e64c6bb2732 : 4155 + 0xd]
02:40:36     INFO -      rbx = 0x000000016ea0c9c0   r12 = 0x000000014a040200
02:40:36     INFO -      r13 = 0x0000000000000001   r14 = 0x00007fff5fbfa9d8
02:40:36     INFO -      r15 = 0x00007fff5fbfa520   rip = 0x0000000103a3a55a
02:40:36     INFO -      rsp = 0x00007fff5fbfa490   rbp = 0x00007fff5fbfa500
02:40:36     INFO -      Found by: call frame info
02:40:36     INFO -   3  XUL!js::jit::IonBuilder::jsop_call(unsigned int, bool) [IonBuilder.cpp:4e64c6bb2732 : 4978 + 0x1d]
02:40:36     INFO -      rbx = 0x00007fff5fbfa5b0   r12 = 0x000000010f06dd00
02:40:36     INFO -      r13 = 0x0000000000000002   r14 = 0x00007fff5fbfa9d8
02:40:36     INFO -      r15 = 0x00007fff5fbfa5a8   rip = 0x0000000103a31721
02:40:36     INFO -      rsp = 0x00007fff5fbfa510   rbp = 0x00007fff5fbfa670
02:40:36     INFO -      Found by: call frame info
02:40:36     INFO -   4  XUL!js::jit::IonBuilder::inspectOpcode(JSOp) [IonBuilder.cpp:4e64c6bb2732 : 1503 + 0x24]
02:40:36     INFO -      rbx = 0x0000000000000052   r12 = 0x0000000000000052
02:40:36     INFO -      r13 = 0x00007fff5fbfa9d8   r14 = 0x0000000000000001
02:40:36     INFO -      r15 = 0x00007fff5fbfa9d8   rip = 0x0000000103a2b6df
02:40:36     INFO -      rsp = 0x00007fff5fbfa680   rbp = 0x00007fff5fbfa730
02:40:36     INFO -      Found by: call frame info
It could be related, but I think the assertion is kind of generic.
(Reporter)

Updated

5 years ago
Summary: Intermittent Crash /test_Range-comparePoint.html | application crashed [@ js::jit::IonBuilder::inlineScriptedCall(js::jit::CallInfo&, JSFunction*)] | Assertion failure: !analysisContext->isExceptionPending(), at /IonBuilder.cpp:3809 and leak → Intermittent Crash /test_Range-comparePoint.html | test_Range-insertNode | application crashed [@ js::jit::IonBuilder::inlineScriptedCall(js::jit::CallInfo&, JSFunction*)] | Assertion failure: !analysisContext->isExceptionPending(), at IonBuilder.cpp:3809
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

5 years ago
Summary: Intermittent Crash /test_Range-comparePoint.html | test_Range-insertNode | application crashed [@ js::jit::IonBuilder::inlineScriptedCall(js::jit::CallInfo&, JSFunction*)] | Assertion failure: !analysisContext->isExceptionPending(), at IonBuilder.cpp:3809 → Intermittent test_Range-comparePoint.html, test_Range-insertNode | application crashed [@ js::jit::IonBuilder::inlineScriptedCall(js::jit::CallInfo&, JSFunction*)] | Assertion failure: !analysisContext->isExceptionPending(), at IonBuilder.cpp:3809
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
This is probably fixed by the patch that just landed in bug 923614.
Comment hidden (Treeherder Robot)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 923614
Keywords: intermittent-failure
You need to log in before you can comment on or make changes to this bug.