Closed Bug 939769 Opened 7 years ago Closed 7 years ago

User can't setup basic email account

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.3+, firefox28 affected)

VERIFIED FIXED
blocking-b2g 1.3+
Tracking Status
firefox28 --- affected

People

(Reporter: Bebe, Unassigned)

References

Details

(Keywords: regression, smoketest, Whiteboard: [xfail])

Attachments

(2 files)

Attached image image_email.png
STR:
1. Open email app:
2. enter your basic credentials (name, email, password)
3. tap next 

Expected:
3. Account is setup and user can use the email account

Actual:
3. we are stuck at setting up email account screen


Reproducing this on 
Inari:
Gaia:     9e3012065962019fa86448daa83b60a9072e9093
Gecko:    http://hg.mozilla.org/mozilla-central/rev/a475f94bb1b1
BuildID   20131116040201
Version   28.0a1

Hamachi on automation:
http://qa-selenium.mv.mozilla.com:8080/view/B2G%20Hamachi/job/b2g.hamachi.mozilla-central.ui/285/


first failed build:
http://qa-selenium.mv.mozilla.com:8080/view/B2G%20Hamachi/job/b2g.hamachi.mozilla-central.ui/285/testReport/?
Tested this with a IMAP setup work flow and the email works 
I used the same gmail email address
Test xfailed in Bug 939771 - xfail test_setup_basic_gmail.py
Bebe - Can you give me more information on the regression range? Specifically:

* The gaia/gecko changeset & build date when the test first failed
* The gaia/gecko changeset & build date when the test last passed
Flags: needinfo?(florin.strugariu)
blocking-b2g: --- → 1.3?
Whiteboard: [xfail]
First failing build:
Gaia:     9e3012065962019fa86448daa83b60a9072e9093
Gecko:    http://hg.mozilla.org/mozilla-central/rev/a475f94bb1b1
BuildID   20131116040201
Version   28.0a1


Last passing build:
Gaia:     ac42cb33f21b3f13595432c965f44615daae2225
Gecko:    http://hg.mozilla.org/mozilla-central/rev/b2fab608772f
BuildID   20131115040200
Version   28.0a1
Flags: needinfo?(florin.strugariu)
The only patch that landed in the email app within that regression range was bug 939353, although that bug doesn't seem like a candidate for causing this regression.
Logcat doesn't say anything interesting either.
There's nothing in the regression range that indicates what caused this bug. Can someone manually check the regression range?
QA Contact: sparsons
The regression window in comment 5 is correct.

This issue started to occur on the Buri 1.3 Build ID: 20131116040201

Gaia   9e3012065962019fa86448daa83b60a9072e9093
SourceStamp a475f94bb1b1
BuildID 20131116040201
Version 28.0a1

Last working Buri 1.3 Build ID: 20131115040200 

Gaia   ac42cb33f21b3f13595432c965f44615daae2225
SourceStamp b2fab608772f
BuildID 20131115040200
Version 28.0a1
It's not impossible that this would be caused by the surface renewal stuff that I landed in that regression range, bug 925608, but it's not certain. The best thing to do here is to bisect this down to 1 changeset. It the culprit is among my patches, the good news is that they're split into a sequence of small patches that should each run correctly, so bisection down to 1 cset will probably pinpoint a very specific issue.
The log says:
I/GeckoDump( 1985): LOG: pushCard for type: setup_progress
I/Gecko   ( 1985): WLOG: Attempting to get autoconfiguration for gmail.com
I/Gecko   ( 1985): WLOG:   Looking in GELAM
I/Gecko   ( 1985): WLOG:   Looking in local file store

Best guess is that XHR broke.  I see bug 927196 name-checking XHR changes, and indeed:
http://hg.mozilla.org/mozilla-central/rev/e6a9c98d62d0#l3.12

Has logic that breaks the e-mail app because we passed mozSystem without mozAnon.

I don't have access to bug 927196 to understand the rationale and I didn't see any announcement e-mails about this change.
The fix for bug 927196 is already backed out.
This issue also fails the importing Facebook smoketest cases along with not being able to import contacts via email.
So today's build is built off a Sunday changeset, which explains why we don't have the backout in today's build.

http://hg.mozilla.org/mozilla-central/rev/d58ab6f6ca0a

So I'm closing this as fixed by backout. Will ask for a respin.
Status: NEW → RESOLVED
blocking-b2g: 1.3? → 1.3+
Closed: 7 years ago
Resolution: --- → FIXED
Verified fixed on Buri using:

Gaia   5d2ce56dbfbba702a487cd17efd19cdd62b2ff57
SourceStamp f2adb62d07eb
BuildID 20131118152945
Version 28.0a1

Verified by setting up a hotmail account and testing with Facebook.
Status: RESOLVED → VERIFIED
Duplicate of this bug: 940481
You need to log in before you can comment on or make changes to this bug.